summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-06-03 11:20:58 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-06-03 11:21:05 +0200
commitd1cc1d2a2e33afbb01aba13c96c07855809de75f (patch)
tree2474a5cf828e9f8e023d1bec22506132e3a41fac /dev-ml
parentdev-util/shtool: Clean up old. (diff)
downloadgentoo-d1cc1d2a2e33afbb01aba13c96c07855809de75f.tar.gz
gentoo-d1cc1d2a2e33afbb01aba13c96c07855809de75f.tar.bz2
gentoo-d1cc1d2a2e33afbb01aba13c96c07855809de75f.zip
dev-ml/ocaml-ctypes: bump to 0.6.0
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-ctypes/Manifest1
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.6.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ctypes/Manifest b/dev-ml/ocaml-ctypes/Manifest
index fdd7d0063984..32089aad347d 100644
--- a/dev-ml/ocaml-ctypes/Manifest
+++ b/dev-ml/ocaml-ctypes/Manifest
@@ -2,3 +2,4 @@ DIST ocaml-ctypes-0.4.1.tar.gz 162601 SHA256 74564e049de5d3c0e76ea284c225cb658ac
DIST ocaml-ctypes-0.4.2.tar.gz 162968 SHA256 704efcbf3b99c180855ad4faed0dd7cec4f2384f9b8963b572329697be8cbae4 SHA512 78e51a4ea35efd6d854b81c65d3e224175927a3c87b9b665d173cefeb3f424e1ed8fc8dfbbb4ce33b4bc43163ecf647ba9b502e69c82eb05ddcde66b8d6c99e4 WHIRLPOOL 124c6f91ae1ae980994f8cca483a2090c60b62864abe8d4b9aac725b2131f331d385a6a1e5b7685e4f61ac4e3e53cb22ac0cad9b32ebefa444d2ef00e15f7caa
DIST ocaml-ctypes-0.5.0.tar.gz 168414 SHA256 d15df8a065b5b9850400727c0e5cb4eb8ad567c3504278b03065cc766b57bf3e SHA512 0d59b6aec0421e7eb79792bfd02a8f77311bca1787f7b17af0eca4fdaa82a55d27de24bc2c6fa937e3c2b86585cd496d929a7490165e27c49da360e6efd3d67d WHIRLPOOL a84b3d14437cf8a47d09d15a3af67b48ed57a147e09d12f93711102879b2962fbe7b4ea1c327e92da262334bed40d8175c9dd18902f8bc4a19f552b97406fd15
DIST ocaml-ctypes-0.5.1.tar.gz 168540 SHA256 51da7276abccb274fd09fda9d024a3469b819d534492afe9c8d549dd953114ec SHA512 03a67c6b995b87c229b04577d2f38a8d699223d5c44c4597e6ac5ff1d74bc22474aea248e9b54d913b83a99ac7ccc61c7c67ca288e4f41b71a63da683b085331 WHIRLPOOL 0eed3a97a7c0fdf568d97b07718171f140aed34d440fa55bb8d21380dddba2f52fa2c3bf61d044da24cd30479c0bdea23bd23b86997adbc14a99bd630fc1ee17
+DIST ocaml-ctypes-0.6.0.tar.gz 179019 SHA256 098980e68c4bd1cad1e859fa2bcea4d3dc8a4f9d04c00bc3ebcf28a7480a3fb7 SHA512 3939df612f4d1aba178737269da55ba85b92730112a5c8011ecd006b61c48d8742b8e5a214662879eb7dc72e5b8a990b587b25696e18b9dda71b5280e1ed1be2 WHIRLPOOL fd11ad1b2624a526c69bda89bb17e45d3a22e3cf4d730734b5a551836034ba9bc057156add0af32ce9f3278d60aadfc2610253c76e53cba7d3aff157d2157dba
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.6.0.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.6.0.ebuild
new file mode 100644
index 000000000000..d563719db9e5
--- /dev/null
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
+SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02:=[ocamlopt]
+ virtual/libffi
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )"
+
+src_compile() {
+ emake -j1
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ findlib_src_install
+ dodoc CHANGES.md README.md
+}