summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-22 10:22:36 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-22 11:06:51 +0100
commitddf8f7ced43098d8159994570837e0507da16315 (patch)
tree2caee28c421e012ddd9cbfdf2296ba7419daaa14 /dev-ml
parentdev-ml/ppx_here: bump to 113.33.00 (diff)
downloadgentoo-ddf8f7ced43098d8159994570837e0507da16315.tar.gz
gentoo-ddf8f7ced43098d8159994570837e0507da16315.tar.bz2
gentoo-ddf8f7ced43098d8159994570837e0507da16315.zip
dev-ml/ppx_fields_conv: bump to 113.33.00
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ppx_fields_conv/Manifest1
-rw-r--r--dev-ml/ppx_fields_conv/ppx_fields_conv-113.33.00.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/ppx_fields_conv/Manifest b/dev-ml/ppx_fields_conv/Manifest
index 395c38ec69a6..45736c0711f6 100644
--- a/dev-ml/ppx_fields_conv/Manifest
+++ b/dev-ml/ppx_fields_conv/Manifest
@@ -1 +1,2 @@
DIST ppx_fields_conv-113.24.00.tar.gz 59020 SHA256 ac77d3db7dafe877713f309bbc991a9c7dbc80a10184e395c1e11bee3b120028 SHA512 6f68be7001cc3a6e95b6ce5e098ba99bea17febf1f39ef1d12e51c5514a1b73a9115fb69ab0c990312394fcd13f141158f9ea1388e1f96239a64629e5369e972 WHIRLPOOL 4dd5bb25def6d9e3025852963f668c4a43c69345e4ab4111593049ee4b98cce5f5f5ded9453d1457a687e7b1c31bfde48bb231b5b9af2ae85928fb494d5e1d16
+DIST ppx_fields_conv-113.33.00.tar.gz 60510 SHA256 33f70d23679530bb50c3b3f518b578a4f6a90a5301032ddb39ba42a42f4b9193 SHA512 cfda9fdefda933c8bd4d7c5791df96642c0ce94a45e5b69b30300d255e4d8a0d8d872008a914f5d51d7611f1a26162af9a56f6b752c9ee33f131ade85d4bfeca WHIRLPOOL 0b30347da9b6dedd87ac4cdaa1fd16f194e6a056b516edaaafa541063720ca0d48791e24eb31ba2bc6374f9aa287835eb879d4dd1d959d26848fccea791b0028
diff --git a/dev-ml/ppx_fields_conv/ppx_fields_conv-113.33.00.ebuild b/dev-ml/ppx_fields_conv/ppx_fields_conv-113.33.00.ebuild
new file mode 100644
index 000000000000..67db485a0326
--- /dev/null
+++ b/dev-ml/ppx_fields_conv/ppx_fields_conv-113.33.00.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+DESCRIPTION="Generation of accessor and iteration functions for ocaml records"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-ml/ppx_tools:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_type_conv:=
+ dev-ml/fieldslib:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam"
+
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md
+}