summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorRafael Kitover <rkitover@gmail.com>2021-06-09 09:54:55 +0000
committerSam James <sam@gentoo.org>2021-06-09 21:35:14 +0000
commitec804ac6c48a59e463a80bf9fbe7cbf7b37f719c (patch)
treefad14d8064853124f8103bc061fdae751d1db484 /dev-ml
parentmedia-libs/gegl: fix IncorrectCopyright (diff)
downloadgentoo-ec804ac6c48a59e463a80bf9fbe7cbf7b37f719c.tar.gz
gentoo-ec804ac6c48a59e463a80bf9fbe7cbf7b37f719c.tar.bz2
gentoo-ec804ac6c48a59e463a80bf9fbe7cbf7b37f719c.zip
dev-ml/ocaml-fileutils: add 0.6.3
No changes to ebuild. Closes: https://bugs.gentoo.org/769233 Signed-off-by: Rafael Kitover <rkitover@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/21172 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-fileutils/Manifest1
-rw-r--r--dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.3.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/ocaml-fileutils/Manifest b/dev-ml/ocaml-fileutils/Manifest
index 215d6c3c6470..da1779a20b3f 100644
--- a/dev-ml/ocaml-fileutils/Manifest
+++ b/dev-ml/ocaml-fileutils/Manifest
@@ -1 +1,2 @@
DIST ocaml-fileutils-0.6.2.tar.bz2 43060 BLAKE2B 20828875a25b1a9d2a41bf495cda00b0ac753efa20111b32a9d2ca439a56e9f07bf0953d16ee9148cf065e204fa1d8d624eaa89f6f4ae7e1613fdaa7cb44fc24 SHA512 104c7389832f22ec189ce6f1596144b28dcaeea7d23d5b19d369c44e54326e97fcb7b4f4c4a8d2965523e63b35b594a1351b7e630dde590871efe512fe38853c
+DIST ocaml-fileutils-0.6.3.tar.bz2 43157 BLAKE2B a9adf17d028abd664dbdec3fefa301a6b502941a6da4ef9c3ef02b876f187d224e404f6a9ffb5460035ba475154c60109a5218cb8b9bb36153ca791f8d218e7d SHA512 2c5e75b894e9f5e3b003d61977a87f5c6964a89d844949eedc55f97c5875cc52052182420bbb4e73925d306479c66400df74e4adfccc5b2102347d13e99505cf
diff --git a/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.3.ebuild b/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.3.ebuild
new file mode 100644
index 000000000000..72c2b68e4139
--- /dev/null
+++ b/dev-ml/ocaml-fileutils/ocaml-fileutils-0.6.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DUNE_PKG_NAME="fileutils"
+
+inherit dune
+
+DESCRIPTION="Pure OCaml functions to manipulate real file (POSIX like) and filename"
+HOMEPAGE="https://github.com/gildor478/ocaml-fileutils"
+SRC_URI="https://github.com/gildor478/${PN}/releases/download/v${PV}/${DUNE_PKG_NAME}-v${PV}.tbz -> ${P}.tar.bz2"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND=">=dev-ml/ounit2-2.0.0
+ >=dev-ml/stdlib-shims-0.2.0"
+
+DOCS=( "README.md" "CHANGES.md" "LICENSE.txt" )
+
+S="${WORKDIR}/${DUNE_PKG_NAME}-v${PV}"
+
+src_prepare() {
+ default
+
+ # Port to dev-ml/ounit2
+ sed -i -e 's/oUnit/ounit2/' test/dune || die
+}