summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-10-13 09:37:18 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-10-13 10:05:52 +0200
commitf1f49c9ae1704b14cb5f264d96419d6a554bce8d (patch)
tree8c84c97771ab8903936e8780ba9adedf28ced278 /dev-ml
parentapp-emulation/xen-pvgrub: bump to eapi 6 (diff)
downloadgentoo-f1f49c9ae1704b14cb5f264d96419d6a554bce8d.tar.gz
gentoo-f1f49c9ae1704b14cb5f264d96419d6a554bce8d.tar.bz2
gentoo-f1f49c9ae1704b14cb5f264d96419d6a554bce8d.zip
dev-ml/ocaml-containers: Remove old
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-containers/Manifest1
-rw-r--r--dev-ml/ocaml-containers/files/qcheck.patch61
-rw-r--r--dev-ml/ocaml-containers/ocaml-containers-1.2.ebuild34
3 files changed, 0 insertions, 96 deletions
diff --git a/dev-ml/ocaml-containers/Manifest b/dev-ml/ocaml-containers/Manifest
index 738af0197e3e..3ca28901adbc 100644
--- a/dev-ml/ocaml-containers/Manifest
+++ b/dev-ml/ocaml-containers/Manifest
@@ -1,2 +1 @@
-DIST ocaml-containers-1.2.tar.gz 293774 SHA256 1c7825fbefaf90c3f9f9367ce0abda95f1dda242b1db560ed51c75ef0c6b5b15 SHA512 c5d94760a51a94aca1482ce3720450bce4448090609737a5be50f99c8884441df4676da953b31bdb8f10dd2fca3235b6e9e8d1580bd3fa917b03408a9a14b28d WHIRLPOOL a365c6992d926d2c4045da0a39052c7eba71eb3c937eca126a186e393fefdf199fe1e40f5cde21539df914e235ce8e3dcd7712da86160a2ef1631cf223c3be65
DIST ocaml-containers-1.3.tar.gz 299928 SHA256 839495aaca4f7bf681b8af931a5de7d51a5076e5c30a5fbf83f4b1de8216aa57 SHA512 d4402be1d11fee883bdf2b4fcc339df6ef175ac2d6532ee865c36656473c4882290e45f2efd9b90af7298fc3ffa0ce27fb83d8c7166edeafff798ceccad929e8 WHIRLPOOL 7292527f99eb92832b7e4b495cfbd6e2fe179d8c1496256f2016489f6f5e8ec0c1509cc5aa05c7af49999b73a0f2eaf77fa6d2bf4310cf68a4762a3ab9a0994e
diff --git a/dev-ml/ocaml-containers/files/qcheck.patch b/dev-ml/ocaml-containers/files/qcheck.patch
deleted file mode 100644
index c88ef31741af..000000000000
--- a/dev-ml/ocaml-containers/files/qcheck.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-commit b2f8eb5b27a95f37509ab6345910ecd62b3c8a90
-Author: Simon Cruanes <simon.cruanes.2007@m4x.org>
-Date: Tue May 30 09:16:37 2017 +0200
-
- update to qcheck 0.6
-
-diff --git a/src/core/CCList.ml b/src/core/CCList.ml
-index ebdf7ce..ef4254e 100644
---- a/src/core/CCList.ml
-+++ b/src/core/CCList.ml
-@@ -688,9 +688,9 @@ let take_while p l =
- *)
-
- (*$Q
-- Q.(pair (fun1 small_int bool) (list small_int)) (fun (f,l) -> \
-- let l1 = take_while f l in \
-- List.for_all f l1)
-+ Q.(pair (fun1 Observable.int bool) (list small_int)) (fun (f,l) -> \
-+ let l1 = take_while (Q.Fn.apply f) l in \
-+ List.for_all (Q.Fn.apply f) l1)
- *)
-
- let rec drop_while p l = match l with
-@@ -698,8 +698,8 @@ let rec drop_while p l = match l with
- | x :: l' -> if p x then drop_while p l' else l
-
- (*$Q
-- Q.(pair (fun1 small_int bool) (list small_int)) (fun (f,l) -> \
-- take_while f l @ drop_while f l = l)
-+ Q.(pair (fun1 Observable.int bool) (list small_int)) (fun (f,l) -> \
-+ take_while (Q.Fn.apply f) l @ drop_while (Q.Fn.apply f) l = l)
- *)
-
- let take_drop_while p l =
-@@ -720,9 +720,9 @@ let take_drop_while p l =
- direct direct_depth_default_ p l
-
- (*$Q
-- Q.(pair (fun1 small_int bool) (list small_int)) (fun (f,l) -> \
-- let l1,l2 = take_drop_while f l in \
-- (l1 = take_while f l) && (l2 = drop_while f l))
-+ Q.(pair (fun1 Observable.int bool) (list small_int)) (fun (f,l) -> \
-+ let l1,l2 = take_drop_while (Q.Fn.apply f) l in \
-+ (l1 = take_while (Q.Fn.apply f) l) && (l2 = drop_while (Q.Fn.apply f) l))
- *)
-
- let last n l =
-diff --git a/src/data/CCRAL.ml b/src/data/CCRAL.ml
-index 0c00c3a..5d9aa24 100644
---- a/src/data/CCRAL.ml
-+++ b/src/data/CCRAL.ml
-@@ -151,7 +151,8 @@ let mapi ~f l =
- *)
-
- (*$Q
-- Q.(pair (list small_int)(fun2 int int bool)) (fun (l,f) -> \
-+ Q.(pair (list small_int)(fun2 Observable.int Observable.int bool)) (fun (l,f) -> \
-+ let f = Q.Fn.apply f in \
- mapi ~f (of_list l) |> to_list = List.mapi f l )
- *)
-
diff --git a/dev-ml/ocaml-containers/ocaml-containers-1.2.ebuild b/dev-ml/ocaml-containers/ocaml-containers-1.2.ebuild
deleted file mode 100644
index 30745be4f65a..000000000000
--- a/dev-ml/ocaml-containers/ocaml-containers-1.2.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-OASIS_BUILD_TESTS=1
-OASIS_BUILD_DOCS=1
-
-inherit oasis
-
-DESCRIPTION="A modular standard library focused on data structures"
-HOMEPAGE="https://github.com/c-cube/ocaml-containers"
-SRC_URI="https://github.com/c-cube/ocaml-containers/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="test"
-
-RDEPEND="
- dev-ml/result:=
- >=dev-ml/sequence-0.9:=
-"
-DEPEND="${RDEPEND} dev-ml/cppo
- test? ( dev-ml/iTeML dev-ml/ounit dev-ml/gen )"
-
-PATCHES=( "${FILESDIR}/qcheck.patch" )
-
-src_configure() {
- oasis_configure_opts="
- --enable-unix
- --disable-bench
- " oasis_src_configure
-}