summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-06-22 18:00:20 +1200
committerKent Fredric <kentnl@gentoo.org>2017-06-22 18:31:09 +1200
commitff0bfa34a537c641ed23f27ac917518c84c90eae (patch)
treea493106e00e71e91f1ae3bc628a5bda1ca6565ea /dev-perl/Algorithm-Dependency/Algorithm-Dependency-1.110.0-r2.ebuild
parentdev-perl/Test-ClassAPI: Fix broken Module::Install::DSL patching (diff)
downloadgentoo-ff0bfa34a537c641ed23f27ac917518c84c90eae.tar.gz
gentoo-ff0bfa34a537c641ed23f27ac917518c84c90eae.tar.bz2
gentoo-ff0bfa34a537c641ed23f27ac917518c84c90eae.zip
dev-perl/Algorithm-Dependency: Fix broken Module::Install::DSL patching
For some rediculous reason, this module changes everything about Perl, so optional newlines cease to be optional. Additionally, this causes configure to exit true, but fail to configure. And this breaks install time, necessitating an -r1 bump. Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Algorithm-Dependency/Algorithm-Dependency-1.110.0-r2.ebuild')
-rw-r--r--dev-perl/Algorithm-Dependency/Algorithm-Dependency-1.110.0-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/Algorithm-Dependency/Algorithm-Dependency-1.110.0-r2.ebuild b/dev-perl/Algorithm-Dependency/Algorithm-Dependency-1.110.0-r2.ebuild
new file mode 100644
index 000000000000..a8989ee19d17
--- /dev/null
+++ b/dev-perl/Algorithm-Dependency/Algorithm-Dependency-1.110.0-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=ADAMK
+MODULE_VERSION=1.110
+inherit perl-module
+
+DESCRIPTION="Toolkit for implementing dependency systems"
+
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND=">=dev-perl/Params-Util-0.31
+ >=virtual/perl-File-Spec-0.82"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Test-ClassAPI )"
+
+SRC_TEST="do"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install::DSL /use lib q[.];\nuse inc::Module::Install::DSL /' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}