summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-04-23 18:56:30 +1200
committerKent Fredric <kentnl@gentoo.org>2020-04-23 18:58:56 +1200
commit5d45bb59adf189257cbd36768297ace578ec8a3b (patch)
treec6aba761b080e350cab466c2d50aacfd4b867417 /dev-perl/Alien-Build/Alien-Build-2.210.0.ebuild
parentvirtual/perl-Archive-Tar: Copy ~riscv from dev-lang/perl (diff)
downloadgentoo-5d45bb59adf189257cbd36768297ace578ec8a3b.tar.gz
gentoo-5d45bb59adf189257cbd36768297ace578ec8a3b.tar.bz2
gentoo-5d45bb59adf189257cbd36768297ace578ec8a3b.zip
dev-perl/Alien-Build: Bump to version 2.210.0
- EAPI7-ify Upstream: - Add configurable log classes - Delay tempfile removal for Test::Alien until 'make clean' on windows. - Test::Alien with_subtest now attempts to catch SEGV and bail with helpful diagnostics - Add Test::Alien::xs_ok options cbuilder_check and cbuilder_config - Add Test::Alien::Diag - Add Test::Alien::ffi_ok option 'api' - Prefer tar.exe on windows (also for unzip) if it is bsdtar - Remove Module::Load - Add OO interface to Alien::Base::Wrapper - Add mm_args2 to Alien::Base::Wrapper - Add WriteMakefile to Alien::Base::Wrapper - Decode::Mojo remembers which version of Mojo::DOM it is using - Prefer Decode::HTML if HTML::Parser is already installed, but Mojolicious or Mojo::DOM58 are not - Add 'use strict' to generated ::Install::Files module - Avoid autoconf plugin bugs on windows if multiple configure scripts are in $PATH - Various helpers for Alien::Build::Interpolate::Default no longer require Aliens tools if already found in $PATH - Prefer nmake or gname over dmake on windows, regardless of what perl is configured with - Add Alien::Build::Plugin::Probe::Vcpkg - Use system temp directory on windows instead of ./ relative tempdir - Build::Autoconf now copies .dll files from bin/ to dynamic directory on Win32 - Add Build::Copy plugin - Better workaround in xs_ok for faux fork on cygwin - Fix regex for Prefer::SortVersions to handle regex with multiple capture groups Package-Manager: Portage-2.3.97, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Alien-Build/Alien-Build-2.210.0.ebuild')
-rw-r--r--dev-perl/Alien-Build/Alien-Build-2.210.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/Alien-Build/Alien-Build-2.210.0.ebuild b/dev-perl/Alien-Build/Alien-Build-2.210.0.ebuild
new file mode 100644
index 000000000000..552c3ef6fdb8
--- /dev/null
+++ b/dev-perl/Alien-Build/Alien-Build-2.210.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PLICEASE
+DIST_VERSION=2.21
+DIST_EXAMPLES=("example/*")
+inherit perl-module
+
+DESCRIPTION="Build external dependencies for use in CPAN"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test zip"
+RESTRICT="!test? ( test )"
+
+# No, pkgconfig is not suspect, it actually uses it at runtime, and this module
+# is somewhat a wrapper for pkgconfig :/
+RDEPEND="
+ zip? ( dev-perl/Archive-Zip )
+ virtual/perl-Archive-Tar
+ >=dev-perl/Capture-Tiny-0.170.0
+ virtual/perl-ExtUtils-CBuilder
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ >=virtual/perl-ExtUtils-ParseXS-3.300.0
+ >=dev-perl/FFI-CheckLib-0.110.0
+ >=dev-perl/File-Which-1.100.0
+ dev-perl/File-chdir
+ virtual/perl-JSON-PP
+ >=dev-perl/Path-Tiny-0.77.0
+ >=virtual/perl-Scalar-List-Utils-1.330.0
+ >=virtual/perl-Test-Simple-1.302.96
+ >=virtual/perl-Text-ParseWords-3.260.0
+ virtual/pkgconfig
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-perl/Devel-Hide
+ >=dev-perl/Test2-Suite-0.0.60
+ )
+"