summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-05-13 18:30:01 +1200
committerKent Fredric <kentnl@gentoo.org>2020-05-13 18:55:54 +1200
commitf12b85d899c939240a932ceeb067f5b67ff130b4 (patch)
tree1aa4e1169d4dd8b8c0f7a7d98fdc2e1d1244b81d /dev-perl/Alien-Build/Alien-Build-2.220.0.ebuild
parentdev-python/appdirs: Bump to 1.4.4 (diff)
downloadgentoo-f12b85d899c939240a932ceeb067f5b67ff130b4.tar.gz
gentoo-f12b85d899c939240a932ceeb067f5b67ff130b4.tar.bz2
gentoo-f12b85d899c939240a932ceeb067f5b67ff130b4.zip
dev-perl/Alien-Build: Bump to version 2.220.0
Upstream: - Add Alien::Base->dynamic_dir Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Alien-Build/Alien-Build-2.220.0.ebuild')
-rw-r--r--dev-perl/Alien-Build/Alien-Build-2.220.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/Alien-Build/Alien-Build-2.220.0.ebuild b/dev-perl/Alien-Build/Alien-Build-2.220.0.ebuild
new file mode 100644
index 000000000000..112d00107825
--- /dev/null
+++ b/dev-perl/Alien-Build/Alien-Build-2.220.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PLICEASE
+DIST_VERSION=2.22
+DIST_EXAMPLES=("example/*")
+inherit perl-module
+
+DESCRIPTION="Build external dependencies for use in CPAN"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test zip"
+RESTRICT="!test? ( test )"
+
+# No, pkgconfig is not suspect, it actually uses it at runtime, and this module
+# is somewhat a wrapper for pkgconfig :/
+RDEPEND="
+ zip? ( dev-perl/Archive-Zip )
+ virtual/perl-Archive-Tar
+ >=dev-perl/Capture-Tiny-0.170.0
+ virtual/perl-ExtUtils-CBuilder
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ >=virtual/perl-ExtUtils-ParseXS-3.300.0
+ >=dev-perl/FFI-CheckLib-0.110.0
+ >=dev-perl/File-Which-1.100.0
+ dev-perl/File-chdir
+ virtual/perl-JSON-PP
+ >=dev-perl/Path-Tiny-0.77.0
+ >=virtual/perl-Scalar-List-Utils-1.330.0
+ >=virtual/perl-Test-Simple-1.302.96
+ >=virtual/perl-Text-ParseWords-3.260.0
+ virtual/pkgconfig
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-perl/Devel-Hide
+ >=dev-perl/Test2-Suite-0.0.60
+ )
+"