summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-17 02:17:51 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-17 02:18:31 +1200
commit25888608c5139d26d655d9afc60ea26c9de4a503 (patch)
tree7d76430a175f3fe2fa1fea835ae5bb88ab53ee6c /dev-perl/Alien-Build
parentdev-perl/Alien-Base-ModuleBuild: Keyword ~x86 (diff)
downloadgentoo-25888608c5139d26d655d9afc60ea26c9de4a503.tar.gz
gentoo-25888608c5139d26d655d9afc60ea26c9de4a503.tar.bz2
gentoo-25888608c5139d26d655d9afc60ea26c9de4a503.zip
dev-perl/Alien-Build: Bump to version 2.290.0
- Add LD!=ccld mitigation, as something in Alien-Build's config routine seems to invoke LD, even though it being the *wrong* LD is seemingly inconsequential, as nothing bad happens from it erroring when trying to pass CFLAGS to LD, but this provision is employed anyway JUST in case. - Add some of the dependencies used by some tests to improve coverage, these are not mandatory, so they've been gated with USE="minimal", but they're pulled by default when testing to give the best possible testing we can offer. Upstream: - Various minor packaging changes Keywording: - Due to new deps I've added for testing, the following keywords needed dropping (don't worry, keyword requests will get filed eventually) for: - alpha, arm, arm64, - hppa, ia64, mips, - ppc, pcc64, riscv, - s390, sparc Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Alien-Build')
-rw-r--r--dev-perl/Alien-Build/Alien-Build-2.290.0.ebuild50
-rw-r--r--dev-perl/Alien-Build/Manifest1
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-perl/Alien-Build/Alien-Build-2.290.0.ebuild b/dev-perl/Alien-Build/Alien-Build-2.290.0.ebuild
new file mode 100644
index 000000000000..51cb8c8a0ce1
--- /dev/null
+++ b/dev-perl/Alien-Build/Alien-Build-2.290.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PLICEASE
+DIST_VERSION=2.29
+DIST_EXAMPLES=("example/*")
+inherit perl-module
+
+DESCRIPTION="Build external dependencies for use in CPAN"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal test zip"
+RESTRICT="!test? ( test )"
+
+# No, pkgconfig is not suspect, it actually uses it at runtime, and this module
+# is somewhat a wrapper for pkgconfig :/
+RDEPEND="
+ zip? ( dev-perl/Archive-Zip )
+ virtual/perl-Archive-Tar
+ >=dev-perl/Capture-Tiny-0.170.0
+ virtual/perl-ExtUtils-CBuilder
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ >=virtual/perl-ExtUtils-ParseXS-3.300.0
+ >=dev-perl/FFI-CheckLib-0.110.0
+ >=dev-perl/File-Which-1.100.0
+ dev-perl/File-chdir
+ virtual/perl-JSON-PP
+ >=dev-perl/Path-Tiny-0.77.0
+ >=virtual/perl-Scalar-List-Utils-1.330.0
+ >=virtual/perl-Test-Simple-1.302.96
+ >=virtual/perl-Text-ParseWords-3.260.0
+ virtual/pkgconfig
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-perl/Devel-Hide
+ >=dev-perl/Test2-Suite-0.0.60
+ !minimal? (
+ dev-perl/Alien-Base-ModuleBuild
+ dev-perl/Sort-Versions
+ )
+ )
+"
+src_prepare() {
+ unset LD
+ [[ -n "${CCLD}" ]] && export LD="${CCLD}"
+ perl-module_src_prepare
+}
diff --git a/dev-perl/Alien-Build/Manifest b/dev-perl/Alien-Build/Manifest
index 2d3559834cf0..d8e22caaa96f 100644
--- a/dev-perl/Alien-Build/Manifest
+++ b/dev-perl/Alien-Build/Manifest
@@ -2,3 +2,4 @@ DIST Alien-Build-1.79.tar.gz 266020 BLAKE2B 265a42ea001b2adad24c3f8164bf795da992
DIST Alien-Build-2.23.tar.gz 310744 BLAKE2B 3bf3ce08be1e508a5eb695cc3ee71ccb70230c3fa0feb3e4378bbba35b7429ab3b852692ea4492e9aa80fdb962ef1fef7e82b654bbf8e8ca2428aa8f999944b8 SHA512 78a9b710dde488ce0852266340104f7b540e94ea58e8715d27e1e303a67956f862110bbd305119ac08fe9c5a20c0e5cc6fa5b6982abf830910f2d3a1ed9963fa
DIST Alien-Build-2.26.tar.gz 313223 BLAKE2B ae51a53806f85662f000951ac58f334ab0920d5468af10d9ea0d814c7f02b7f7eada8698db01fa52735599938d18c171f566359e45c90fae03895b12d3e7c8b1 SHA512 d5e407e5865dcf6771016cd9b182c9a6f982e6dd2c56ea8ea20b32603dc824f99b1f5ee8d460fa2e412aefbf82f09e338b513ab57ebcfc0fa6e200d103060f48
DIST Alien-Build-2.28.tar.gz 314626 BLAKE2B c37bf00f937a1390ba3e35b1a26b676d72b20e0849cbad954e54c04693f1d677aa225be790cd4c68a7df3042c4b2759f8d3a097cbf8480170f1e93327876f765 SHA512 3fe1b0536bce723b925345dad2993b4d8a128d873476ab307d4f06d5ee6ac28f96f07a85345deda2af6cee2f4305f4ff7886ca97bf2ffe1ff05a7e1098784966
+DIST Alien-Build-2.29.tar.gz 313997 BLAKE2B 2a72d07efa899f5d2314db5fffadfbc304db4105dcca1f0f30557d4bbe292c902deca3d064f7909fc84cf9df9f88c6eb6d3b51225ad6d8ccae0cd1e7dbf52ba0 SHA512 7e6ad1695fcfc9ff98764e77a87014a6617c0e27f427d26f70a7fe0daa379963f73fe16e9993de87540e71070e696345bec41fc21c0e7003a144d94413a8522d