summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/AnyEvent-I3
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/AnyEvent-I3')
-rw-r--r--dev-perl/AnyEvent-I3/AnyEvent-I3-0.150.0.ebuild27
-rw-r--r--dev-perl/AnyEvent-I3/AnyEvent-I3-0.160.0.ebuild29
-rw-r--r--dev-perl/AnyEvent-I3/Manifest2
-rw-r--r--dev-perl/AnyEvent-I3/metadata.xml9
4 files changed, 67 insertions, 0 deletions
diff --git a/dev-perl/AnyEvent-I3/AnyEvent-I3-0.150.0.ebuild b/dev-perl/AnyEvent-I3/AnyEvent-I3-0.150.0.ebuild
new file mode 100644
index 000000000000..8866d4b7987c
--- /dev/null
+++ b/dev-perl/AnyEvent-I3/AnyEvent-I3-0.150.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MSTPLBG
+MODULE_VERSION=0.15
+inherit perl-module
+
+DESCRIPTION="Communicate with the i3 window manager"
+
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE=""
+
+COMMON_DEPEND="
+ dev-perl/AnyEvent
+ dev-perl/JSON-XS
+"
+DEPEND="
+ ${COMMON_DEPEND}
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+"
+#SRC_TEST="do"
diff --git a/dev-perl/AnyEvent-I3/AnyEvent-I3-0.160.0.ebuild b/dev-perl/AnyEvent-I3/AnyEvent-I3-0.160.0.ebuild
new file mode 100644
index 000000000000..a74a10227a74
--- /dev/null
+++ b/dev-perl/AnyEvent-I3/AnyEvent-I3-0.160.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MSTPLBG
+MODULE_VERSION=0.16
+inherit perl-module
+
+DESCRIPTION="Communicate with the i3 window manager"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ dev-perl/AnyEvent
+ dev-perl/JSON-XS
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/AnyEvent-I3/Manifest b/dev-perl/AnyEvent-I3/Manifest
new file mode 100644
index 000000000000..99a663bf9771
--- /dev/null
+++ b/dev-perl/AnyEvent-I3/Manifest
@@ -0,0 +1,2 @@
+DIST AnyEvent-I3-0.15.tar.gz 24665 SHA256 116f28225cb8d422eb6f30941c0430b786d340c731b763bb7a6d1d630c881f75 SHA512 0dab5b5cfc3aa454f8acfb09ab27e70e9cb999bcf881cd8b8ae9d0414169b5c59c27619c36bcadcad1d819ff96be8f102036c475bd7f24d1762c50b63597be68 WHIRLPOOL 7cdfd40426ac4cfa119dde24dee4af219155bdf1361bf3eb137d76d98f945c2c19d77430ceca9ef5182f34e84900fec0f8769f55a99db192d36fbb91bea672c9
+DIST AnyEvent-I3-0.16.tar.gz 25320 SHA256 2fc2010011462b6ac9f64dbc5049c5a4298020b9f0f3340d4d22d95a77519be3 SHA512 20d2ea27deaed4b6fcdc818c94c92699e2ae83cc7a655f4ccbde8e77771ec9ba27a577c7585f31e77b11796f2c414bfe719b695c4f9b6fb206e17ec8b09822e1 WHIRLPOOL 8323843067c677eed0e602bcbafd0b8b490267d785481e135d33a74bc9d747c207e6cfdc9d30b607d5bd0fe727800bf1b0fc6aa24d005d31d62e805da886cb8e
diff --git a/dev-perl/AnyEvent-I3/metadata.xml b/dev-perl/AnyEvent-I3/metadata.xml
new file mode 100644
index 000000000000..f46c5a710462
--- /dev/null
+++ b/dev-perl/AnyEvent-I3/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">AnyEvent-I3</remote-id>
+ <remote-id type="cpan-module">AnyEvent::I3</remote-id>
+ </upstream>
+</pkgmetadata>