summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-11-21 12:57:27 +1300
committerKent Fredric <kentnl@gentoo.org>2016-11-21 16:36:05 +1300
commit6eb6e6b6522a9c7be1e3fa09648912214ecacdfc (patch)
tree101e8c9cc5d257e68d4a2d6d161f2064cdbf4766 /dev-perl/Archive-Tar-Wrapper/Archive-Tar-Wrapper-0.230.0.ebuild
parentnet-irc/unrealircd: remove vulnerable wrt sec bug #593294 (diff)
downloadgentoo-6eb6e6b6522a9c7be1e3fa09648912214ecacdfc.tar.gz
gentoo-6eb6e6b6522a9c7be1e3fa09648912214ecacdfc.tar.bz2
gentoo-6eb6e6b6522a9c7be1e3fa09648912214ecacdfc.zip
dev-perl/Archive-Tar-Wrapper: Add w/ version 0.230.0
This is a recommended requirement for Dist-Zilla as it is substantially faster than using a Perl implementation of Tar for the same purpose. Explicit dependency on app-arch/tar due to this modules purpose being oriented around tar, or gnu tar, and may not work with other implementations. Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-perl/Archive-Tar-Wrapper/Archive-Tar-Wrapper-0.230.0.ebuild')
-rw-r--r--dev-perl/Archive-Tar-Wrapper/Archive-Tar-Wrapper-0.230.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Archive-Tar-Wrapper/Archive-Tar-Wrapper-0.230.0.ebuild b/dev-perl/Archive-Tar-Wrapper/Archive-Tar-Wrapper-0.230.0.ebuild
new file mode 100644
index 000000000000..2c58d29ae9dd
--- /dev/null
+++ b/dev-perl/Archive-Tar-Wrapper/Archive-Tar-Wrapper-0.230.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=MSCHILLI
+DIST_VERSION=0.23
+DIST_EXAMPLES=("eg/*")
+inherit perl-module
+
+DESCRIPTION="API wrapper around the 'tar' utility"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# r:Cwd -> File-Spec
+RDEPEND="
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ dev-perl/File-Which
+ dev-perl/IPC-Run
+ dev-perl/Log-Log4perl
+ virtual/perl-File-Path
+ app-arch/tar
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"