summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-22 03:49:50 +0100
committerSam James <sam@gentoo.org>2024-05-22 03:49:50 +0100
commit0e6bd716734640dc370cacb392cc9cfd6b19c6aa (patch)
tree717fba0307a321d7b13ea4d854600b9900bc5a50 /dev-perl/Audio-Scan
parentdev-perl/Audio-Mixer: EAPI 8, rely on eclass impls (diff)
downloadgentoo-0e6bd716734640dc370cacb392cc9cfd6b19c6aa.tar.gz
gentoo-0e6bd716734640dc370cacb392cc9cfd6b19c6aa.tar.bz2
gentoo-0e6bd716734640dc370cacb392cc9cfd6b19c6aa.zip
dev-perl/Audio-Scan: EAPI 8, rely on eclass impls
This covers more variables/args, etc. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Audio-Scan')
-rw-r--r--dev-perl/Audio-Scan/Audio-Scan-1.10.0-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Audio-Scan/Audio-Scan-1.10.0-r2.ebuild b/dev-perl/Audio-Scan/Audio-Scan-1.10.0-r2.ebuild
new file mode 100644
index 000000000000..1123ee4767af
--- /dev/null
+++ b/dev-perl/Audio-Scan/Audio-Scan-1.10.0-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=AGRUNDMA
+DIST_VERSION=1.01
+inherit perl-module
+
+DESCRIPTION="Fast C metadata and tag reader for all common audio file formats"
+
+# License note: ambiguity: https://rt.cpan.org/Ticket/Display.html?id=132450
+# Tagged GPL-2 since this seems to be the smallest common denominator
+# Leaving the rest for upstream to sort out
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Warn
+ )
+"
+
+PERL_RM_FILES=(
+ "t/02pod.t"
+ "t/03podcoverage.t"
+ "t/04critic.t"
+)