summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-04-30 09:49:09 +1200
committerKent Fredric <kentnl@gentoo.org>2020-04-30 10:12:15 +1200
commitba2d8ee2d9aa69fadccac2ad9b4cd6dba642d486 (patch)
treecf2680a32845da927d79226ff90c86da741ab37f /dev-perl/Authen-DigestMD5
parentmedia-libs/vulkan-layers: Bump to 1.2.137 (diff)
downloadgentoo-ba2d8ee2d9aa69fadccac2ad9b4cd6dba642d486.tar.gz
gentoo-ba2d8ee2d9aa69fadccac2ad9b4cd6dba642d486.tar.bz2
gentoo-ba2d8ee2d9aa69fadccac2ad9b4cd6dba642d486.zip
dev-perl/Authen-DigestMD5: -r bump for EAPI7
- EAPI7 - Move digest-md5-auth.pl to be an example - Add USE="examples" - Parallel tests - Remove empty variable assignments Package-Manager: Portage-2.3.97, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Authen-DigestMD5')
-rw-r--r--dev-perl/Authen-DigestMD5/Authen-DigestMD5-0.40.0-r2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-perl/Authen-DigestMD5/Authen-DigestMD5-0.40.0-r2.ebuild b/dev-perl/Authen-DigestMD5/Authen-DigestMD5-0.40.0-r2.ebuild
new file mode 100644
index 000000000000..811b8de8e55e
--- /dev/null
+++ b/dev-perl/Authen-DigestMD5/Authen-DigestMD5-0.40.0-r2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SALVA
+DIST_VERSION=0.04
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="SASL DIGEST-MD5 authentication (RFC2831)"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+src_prepare() {
+ mkdir -p examples || die "Can't mkdir examples"
+ mv -v digest-md5-auth.pl examples/ || die "Can't move digest-md5-auth.pl"
+ sed -i -r -e 's|^(digest-md5-auth.pl)|examples/\1|' MANIFEST || die "Can't fix manifest"
+ perl-module_src_prepare
+}