summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-04-18 00:40:11 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-04-18 00:43:04 +0200
commit95c8417fd2055f84f94004abee22bf1cb4466fa5 (patch)
treec274c86b5dda7d48056412aeaec7f0b5d6d859bd /dev-perl/Authen-Radius
parentdev-perl/Astro-FITS-Header: Version bump (diff)
downloadgentoo-95c8417fd2055f84f94004abee22bf1cb4466fa5.tar.gz
gentoo-95c8417fd2055f84f94004abee22bf1cb4466fa5.tar.bz2
gentoo-95c8417fd2055f84f94004abee22bf1cb4466fa5.zip
dev-perl/Authen-Radius: Version bump 0.32
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Authen-Radius')
-rw-r--r--dev-perl/Authen-Radius/Authen-Radius-0.320.0.ebuild50
-rw-r--r--dev-perl/Authen-Radius/Manifest1
-rw-r--r--dev-perl/Authen-Radius/files/Authen-Radius-0.32-no-install-db.patch43
3 files changed, 94 insertions, 0 deletions
diff --git a/dev-perl/Authen-Radius/Authen-Radius-0.320.0.ebuild b/dev-perl/Authen-Radius/Authen-Radius-0.320.0.ebuild
new file mode 100644
index 000000000000..bff0006635e2
--- /dev/null
+++ b/dev-perl/Authen-Radius/Authen-Radius-0.320.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PORTAONE
+DIST_VERSION=0.32
+DIST_EXAMPLES=("contrib/*")
+inherit perl-module
+
+DESCRIPTION="Communicate with a Radius server from Perl"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=virtual/perl-Data-Dumper-1.0.0
+ >=dev-perl/Data-HexDump-0.20.0
+ >=virtual/perl-Digest-MD5-2.200.0
+ >=virtual/perl-IO-1.120.0
+ >=dev-perl/Net-IP-1.260.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ test? (
+ dev-perl/Test-NoWarnings
+ virtual/perl-Test-Simple
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.26-cisco-dictionary.patch
+ "${FILESDIR}"/${PN}-0.32-no-install-db.patch
+)
+
+src_configure() {
+ export OPTIMIZE="$CFLAGS"
+ perl-module_src_configure
+}
+
+src_install() {
+ perl-module_src_install
+
+ # Really want to install these radius dictionaries?
+ insinto /etc/raddb
+ doins raddb/dictionary*
+}
diff --git a/dev-perl/Authen-Radius/Manifest b/dev-perl/Authen-Radius/Manifest
index 4b13a5bff126..1b2a14480fe4 100644
--- a/dev-perl/Authen-Radius/Manifest
+++ b/dev-perl/Authen-Radius/Manifest
@@ -1 +1,2 @@
DIST Authen-Radius-0.31.tar.gz 51311 BLAKE2B 52aaa623ca28b1b406c027fb54f38c9f24b347815aefb3336649b4ff505a0b97db516b6877546bd330505516f3481934b0c46975c017ae76ed475bc476bd1c6d SHA512 6b78254a6a94f67bd3a5529d4313da779d630a57e2300b02a49034c153b34fec0c6e745c5419f5a5e3ba2996d39907834d3f909ce9fdbd0edc6c43668f89d380
+DIST Authen-Radius-0.32.tar.gz 51366 BLAKE2B 12b18554fccd56aa3668224e2e1a932108993ef845b10b3220eed212fb3413d875cdeb8e8fdef2ba439b0b0ab72417bbb9c830bc2a023a03a0c221b3f52b3170 SHA512 323bddead9465d60da8d1b0f4500fec436c14a8c82552b24da54a6798c0583dffb37005f7abc627ea9532ca46bd442063cddd52d8c5923aa10fa7954c728bca5
diff --git a/dev-perl/Authen-Radius/files/Authen-Radius-0.32-no-install-db.patch b/dev-perl/Authen-Radius/files/Authen-Radius-0.32-no-install-db.patch
new file mode 100644
index 000000000000..149d3b465a17
--- /dev/null
+++ b/dev-perl/Authen-Radius/files/Authen-Radius-0.32-no-install-db.patch
@@ -0,0 +1,43 @@
+From 57b9f1a710c2eee1c8f54eb87d164584aa9532ce Mon Sep 17 00:00:00 2001
+From: Torsten Veller <tove@gentoo.org>
+Date: Mon, 5 Nov 2012 01:02:48 +1300
+Subject: Remove automatic radis-db installer code
+
+---
+ MANIFEST | 1 -
+ Makefile.PL | 1 -
+ install-radius-db.PL => install-radius-db.PL.orig | 0
+ 3 files changed, 2 deletions(-)
+ rename install-radius-db.PL => install-radius-db.PL.orig (100%)
+
+diff --git a/MANIFEST b/MANIFEST
+index a8e2801..09913da 100644
+--- a/MANIFEST
++++ b/MANIFEST
+@@ -4,7 +4,6 @@ README
+ LICENSE
+ MANIFEST
+ Radius.pm
+-install-radius-db.PL
+ t/decode.t
+ t/dictionary.t
+ t/digest.t
+diff --git a/Makefile.PL b/Makefile.PL
+index 45653ab..7f1b202 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -4,7 +4,6 @@ use ExtUtils::MakeMaker;
+ WriteMakefile(
+ NAME => 'Authen::Radius',
+ VERSION_FROM => 'Radius.pm', # finds $VERSION
+- PPM_INSTALL_SCRIPT => 'install-radius-db.PL',
+ MIN_PERL_VERSION => "v5.10.0",
+ BUILD_REQUIRES => {
+ # Support for TEST_REQUIRES
+diff --git a/install-radius-db.PL b/install-radius-db.PL.orig
+similarity index 100%
+rename from install-radius-db.PL
+rename to install-radius-db.PL.orig
+--
+2.15.1
+