summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-04-16 05:55:08 +1200
committerKent Fredric <kentnl@gentoo.org>2018-04-16 05:55:44 +1200
commit21e83184b2036d8209b51901a8a87172212ed759 (patch)
treea47efd5c310705e6e91104f86c27d066df1e9bc7 /dev-perl/Authen-SCRAM/Authen-SCRAM-0.9.0.ebuild
parentdev-libs/gmp: drop USE=pgo (bitrot), bug #650558 (diff)
downloadgentoo-21e83184b2036d8209b51901a8a87172212ed759.tar.gz
gentoo-21e83184b2036d8209b51901a8a87172212ed759.tar.bz2
gentoo-21e83184b2036d8209b51901a8a87172212ed759.zip
dev-perl/Authen-SCRAM: Bump to version 0.9.0
Upstream: - Computed digests is now cached in clients were salt and iteration count are the same. - Normalize stored strings when doing SASLprep - Add "minimum_iteration_count" defaulting to 4096 to mitigate downgrade attacks - Add "computed_keysz" client method - Fix mojibaking of wide characters in usernames Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Authen-SCRAM/Authen-SCRAM-0.9.0.ebuild')
-rw-r--r--dev-perl/Authen-SCRAM/Authen-SCRAM-0.9.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Authen-SCRAM/Authen-SCRAM-0.9.0.ebuild b/dev-perl/Authen-SCRAM/Authen-SCRAM-0.9.0.ebuild
new file mode 100644
index 000000000000..c66d0d570901
--- /dev/null
+++ b/dev-perl/Authen-SCRAM/Authen-SCRAM-0.9.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DAGOLDEN
+DIST_VERSION=0.009
+inherit perl-module
+
+DESCRIPTION="Salted Challenge Response Authentication Mechanism (RFC 5802)"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Authen-SASL-SASLprep
+ virtual/perl-Carp
+ dev-perl/Crypt-URandom
+ virtual/perl-Encode
+ virtual/perl-MIME-Base64
+ >=dev-perl/Moo-1.1.0
+ >=dev-perl/PBKDF2-Tiny-0.3.0
+ dev-perl/Try-Tiny
+ dev-perl/Type-Tiny
+ dev-perl/namespace-clean
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ test? (
+ virtual/perl-Exporter
+ virtual/perl-File-Spec
+ dev-perl/Test-FailWarnings
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"