summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Huettel (dilfridge) <dilfridge@gentoo.org>2015-09-29 22:44:49 +0200
committerAndreas K. Huettel (dilfridge) <dilfridge@gentoo.org>2015-09-29 23:09:14 +0200
commite599ab3b8b20d1b664bfe48f1fd18aa39e7ceb0a (patch)
treeb79083a2cfb9c3c04654e6e27061f2ef1c128355 /dev-perl/B-OPCheck/B-OPCheck-0.300.0.ebuild
parentdev-perl/Archive-Zip: Version bump; remove old (diff)
downloadgentoo-e599ab3b8b20d1b664bfe48f1fd18aa39e7ceb0a.tar.gz
gentoo-e599ab3b8b20d1b664bfe48f1fd18aa39e7ceb0a.tar.bz2
gentoo-e599ab3b8b20d1b664bfe48f1fd18aa39e7ceb0a.zip
dev-perl/B-OPCheck: Version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-perl/B-OPCheck/B-OPCheck-0.300.0.ebuild')
-rw-r--r--dev-perl/B-OPCheck/B-OPCheck-0.300.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/B-OPCheck/B-OPCheck-0.300.0.ebuild b/dev-perl/B-OPCheck/B-OPCheck-0.300.0.ebuild
new file mode 100644
index 000000000000..fad7415aeb3f
--- /dev/null
+++ b/dev-perl/B-OPCheck/B-OPCheck-0.300.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=ETHER
+MODULE_VERSION=0.30
+inherit perl-module
+
+DESCRIPTION="PL_check hacks using Perl callbacks"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/B-Utils-0.80.0
+ virtual/perl-Carp
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Scope-Guard
+ virtual/perl-XSLoader
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/ExtUtils-Depends-0.302.0
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-Test-Simple
+ )
+"
+
+PATCHES=( "${FILESDIR}"/0.29-Perl_check_t.patch )
+SRC_TEST=do