summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-04 01:42:12 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-04 02:59:50 +1200
commitb0bc78346e4260d67d1e4d398474e30af82f006b (patch)
tree18a1f5a6972c9da22da4e209baadae131cae5f2b /dev-perl/B-OPCheck
parentdev-perl/B-Hooks-Parser: -r bump for CFLAGS love (diff)
downloadgentoo-b0bc78346e4260d67d1e4d398474e30af82f006b.tar.gz
gentoo-b0bc78346e4260d67d1e4d398474e30af82f006b.tar.bz2
gentoo-b0bc78346e4260d67d1e4d398474e30af82f006b.zip
dev-perl/B-OPCheck: -r bump for EAPI7 + CFLAGS love
- EAPI7 - Ensure CFLAGS passed to make/compile Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/B-OPCheck')
-rw-r--r--dev-perl/B-OPCheck/B-OPCheck-0.320.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/B-OPCheck/B-OPCheck-0.320.0-r1.ebuild b/dev-perl/B-OPCheck/B-OPCheck-0.320.0-r1.ebuild
new file mode 100644
index 000000000000..2c2e6ab8c967
--- /dev/null
+++ b/dev-perl/B-OPCheck/B-OPCheck-0.320.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.32
+inherit perl-module
+
+DESCRIPTION="PL_check hacks using Perl callbacks"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-perl/B-Utils-0.80.0
+ virtual/perl-Carp
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Scope-Guard
+ virtual/perl-XSLoader
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/ExtUtils-Depends-0.302.0
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-Module-Metadata
+ virtual/perl-Test-Simple
+ )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}