summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-22 05:27:33 +0100
committerSam James <sam@gentoo.org>2024-05-22 05:34:29 +0100
commit3c18e1b346ddb617889d4b607de55793e1b5c96c (patch)
tree770c4f46c7153cf7e63447c02010a02b64d913f4 /dev-perl/B-Utils
parentdev-perl/B-OPCheck: EAPI 8, rely on eclass impls (diff)
downloadgentoo-3c18e1b346ddb617889d4b607de55793e1b5c96c.tar.gz
gentoo-3c18e1b346ddb617889d4b607de55793e1b5c96c.tar.bz2
gentoo-3c18e1b346ddb617889d4b607de55793e1b5c96c.zip
dev-perl/B-Utils: EAPI 8, rely on eclass impls
This covers more variables/args, etc. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/B-Utils')
-rw-r--r--dev-perl/B-Utils/B-Utils-0.270.0-r3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/B-Utils/B-Utils-0.270.0-r3.ebuild b/dev-perl/B-Utils/B-Utils-0.270.0-r3.ebuild
new file mode 100644
index 000000000000..15f3b55b9b86
--- /dev/null
+++ b/dev-perl/B-Utils/B-Utils-0.270.0-r3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.27
+inherit perl-module
+
+DESCRIPTION="Helper functions for op tree manipulation"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
+
+# needs Scalar::Util
+RDEPEND="
+ virtual/perl-Exporter
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Task-Weaken
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-CBuilder
+ >=dev-perl/ExtUtils-Depends-0.301.0
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+
+PERL_RM_FILES=(
+ # These useless no-op tests that simply clutter test output
+ t/utils/{31oldname,32kids,33ancestors,34descendants,35siblings,36previous,37stringify}.t
+ t/utils/{41walkfilt,42all,43allfilt,44optrep}.t
+ t/utils/{50carp,51croak}.t
+)