summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2018-05-01 14:11:29 +0100
committerMarek Szuba <marecki@gentoo.org>2018-05-01 14:12:08 +0100
commit4f1be5045ba43a9e9596d89ab2d47e50880f6537 (patch)
tree5e53d8c0e1b74b47619942f5b14e36a4439edd99 /dev-perl/Bio-DB-HTS/Bio-DB-HTS-2.11.ebuild
parentdev-python/pypcap: Version 1.2.1. (diff)
downloadgentoo-4f1be5045ba43a9e9596d89ab2d47e50880f6537.tar.gz
gentoo-4f1be5045ba43a9e9596d89ab2d47e50880f6537.tar.bz2
gentoo-4f1be5045ba43a9e9596d89ab2d47e50880f6537.zip
dev-perl/Bio-DB-HTS: bump to 2.11
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Bio-DB-HTS/Bio-DB-HTS-2.11.ebuild')
-rw-r--r--dev-perl/Bio-DB-HTS/Bio-DB-HTS-2.11.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Bio-DB-HTS/Bio-DB-HTS-2.11.ebuild b/dev-perl/Bio-DB-HTS/Bio-DB-HTS-2.11.ebuild
new file mode 100644
index 000000000000..e5c23d67da05
--- /dev/null
+++ b/dev-perl/Bio-DB-HTS/Bio-DB-HTS-2.11.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=AVULLO
+DIST_VERSION=2.11
+
+inherit perl-module
+
+DESCRIPTION="Perl bindings for sci-libs/htslib"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="sci-biology/bioperl
+ sci-libs/htslib:="
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? ( dev-perl/Test-LeakTrace )"
+
+PATCHES=(
+ "${FILESDIR}/2.11-build_split_htslib_opts.patch"
+)
+
+src_configure() {
+ local myconf="--htslib-includedir=${EPREFIX}/usr/include/htslib --htslib-libdir=${EPREFIX}/usr/$(get_libdir)"
+ perl-module_src_configure
+}