summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-09-10 15:20:29 +1200
committerKent Fredric <kentnl@gentoo.org>2017-09-10 15:22:39 +1200
commit29bb345f1ea0a356c7e7e4eca3ab3bc405a7d846 (patch)
tree880a3a18b4d3c3ac188abb9f8cdef07052a768f1 /dev-perl/Bio-SamTools/Bio-SamTools-1.430.0.ebuild
parentdev-python/oauthlib: version bump to 2.0.3 (diff)
downloadgentoo-29bb345f1ea0a356c7e7e4eca3ab3bc405a7d846.tar.gz
gentoo-29bb345f1ea0a356c7e7e4eca3ab3bc405a7d846.tar.bz2
gentoo-29bb345f1ea0a356c7e7e4eca3ab3bc405a7d846.zip
dev-perl/Bio-SamTools: Bump to version 1.430.0
- Links against samtools:0.1-legacy series, as even though this code previously attempted to use 1.0+, closer inspection indicated incomplete linking, missing symbols, and failing tests introduced by this attempt. Additionally, upstream EXPLICITLY STATE the lack of current support for samtools 1.0 - Restores DIST_TEST as I can now test they work - Fold swathe of sed commands into patch Upstream: - Ship some test files requried for tests to pass Closes: https://bugs.gentoo.org/611970 Closes: https://bugs.gentoo.org/604950 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Bio-SamTools/Bio-SamTools-1.430.0.ebuild')
-rw-r--r--dev-perl/Bio-SamTools/Bio-SamTools-1.430.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Bio-SamTools/Bio-SamTools-1.430.0.ebuild b/dev-perl/Bio-SamTools/Bio-SamTools-1.430.0.ebuild
new file mode 100644
index 000000000000..1147cec5a486
--- /dev/null
+++ b/dev-perl/Bio-SamTools/Bio-SamTools-1.430.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=LDS
+DIST_VERSION=1.43
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="Read SAM/BAM database files"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+LICENSE="|| ( Apache-2.0 Artistic-2 GPL-1+ )"
+
+RDEPEND="
+ >=sci-biology/bioperl-1.6.9
+ sci-biology/samtools:0.1-legacy=
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-CBuilder
+ >=dev-perl/Module-Build-0.420.0
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.430.0-legacy.patch
+)
+
+src_prepare() {
+ perl-module_src_prepare
+ tc-export CC
+}