summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-05-07 23:27:25 +1200
committerKent Fredric <kentnl@gentoo.org>2020-05-07 23:28:27 +1200
commit1212602b3e99e3b490c8e00e657105cfe8dc520d (patch)
tree9222b2686f9968f2f546792ce18e8e4f3c1a9a23 /dev-perl/CGI-Simple/CGI-Simple-1.250.0.ebuild
parentdev-java/java-config: add python3_8 compat (diff)
downloadgentoo-1212602b3e99e3b490c8e00e657105cfe8dc520d.tar.gz
gentoo-1212602b3e99e3b490c8e00e657105cfe8dc520d.tar.bz2
gentoo-1212602b3e99e3b490c8e00e657105cfe8dc520d.zip
dev-perl/CGI-Simple: Bump to version 1.250.0
- EAPI7 - Fix license as best I can re bug #721422 - Parallel tests - Remove empty variable assignments and useless/no longer needed variables/logic. Upstream: - Don't attempt to decode PUTDATA or POSTDATA if utf8 or NO_NULL is set - Add SameSite support to Cookie handling - Fix handling of max-age attribute in constructor - Correct string value of "Found" for 302 responses as per RFC 2616 - Avoid warnings in STORE - Add samesite parameter to ->cookie(...) Bug: https://bugs.gentoo.org/721422 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/CGI-Simple/CGI-Simple-1.250.0.ebuild')
-rw-r--r--dev-perl/CGI-Simple/CGI-Simple-1.250.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/CGI-Simple/CGI-Simple-1.250.0.ebuild b/dev-perl/CGI-Simple/CGI-Simple-1.250.0.ebuild
new file mode 100644
index 000000000000..99f89b07367f
--- /dev/null
+++ b/dev-perl/CGI-Simple/CGI-Simple-1.250.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MANWAR
+DIST_VERSION=1.25
+inherit perl-module
+
+DESCRIPTION="A Simple totally OO CGI interface that is CGI.pm compliant"
+# Bug: https://bugs.gentoo.org/721422
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-perl/Module-Build
+"
+BDEPEND="
+ dev-perl/Module-Build
+ test? (
+ dev-perl/libwww-perl
+ dev-perl/IO-stringy
+ virtual/perl-File-Temp
+ dev-perl/Test-Exception
+ dev-perl/Test-NoWarnings
+ )
+"