summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-05-08 01:44:11 +1200
committerKent Fredric <kentnl@gentoo.org>2020-05-08 01:53:50 +1200
commita58af4c60f6761c036b800db6a2dd37e6e5abaea (patch)
tree7174c4ab386d8b2d138ba763733ee3d84a2d3656 /dev-perl/CQL-Parser/CQL-Parser-1.130.0-r1.ebuild
parentdev-util/idea-community: Version bump to 1.1 (diff)
downloadgentoo-a58af4c60f6761c036b800db6a2dd37e6e5abaea.tar.gz
gentoo-a58af4c60f6761c036b800db6a2dd37e6e5abaea.tar.bz2
gentoo-a58af4c60f6761c036b800db6a2dd37e6e5abaea.zip
dev-perl/CQL-Parser: -r bump for EAPI7
- EAPI7 - Parallel tests - Use "patch" instead of "sed" - Fix license as best I can re bug #721472 Bug: https://bugs.gentoo.org/721472 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/CQL-Parser/CQL-Parser-1.130.0-r1.ebuild')
-rw-r--r--dev-perl/CQL-Parser/CQL-Parser-1.130.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/CQL-Parser/CQL-Parser-1.130.0-r1.ebuild b/dev-perl/CQL-Parser/CQL-Parser-1.130.0-r1.ebuild
new file mode 100644
index 000000000000..c10924c45dd7
--- /dev/null
+++ b/dev-perl/CQL-Parser/CQL-Parser-1.130.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=BRICAS
+DIST_VERSION=1.13
+inherit perl-module
+
+DESCRIPTION="compiles CQL strings into parse trees of Node subtypes"
+# Bug: https://bugs.gentoo.org/721472
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-perl/Class-Accessor-0.100.0
+ >=dev-perl/Clone-0.150.0
+ >=dev-perl/String-Tokenizer-0.50.0
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ test? (
+ dev-perl/Test-Exception
+ virtual/perl-Test-Simple
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.13-no-dot-inc.patch"
+)