summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-04 13:35:29 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-06 06:23:26 +1200
commite11e9e62ee039da628f73d451681de3b8964be5c (patch)
tree42ac821db76b25a25894df33af28b2803e40a71e /dev-perl/Cairo/Cairo-1.107.0-r1.ebuild
parentdev-perl/Cache-Memcached-Fast: -r bump for CFLAGS love (diff)
downloadgentoo-e11e9e62ee039da628f73d451681de3b8964be5c.tar.gz
gentoo-e11e9e62ee039da628f73d451681de3b8964be5c.tar.bz2
gentoo-e11e9e62ee039da628f73d451681de3b8964be5c.zip
dev-perl/Cairo: -r bump for CFLAGS love
- Ensure x11-libs/cairo in DEPEND, as we link to it. - Ensure CFLAGS passed to make/compiler Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Cairo/Cairo-1.107.0-r1.ebuild')
-rw-r--r--dev-perl/Cairo/Cairo-1.107.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/Cairo/Cairo-1.107.0-r1.ebuild b/dev-perl/Cairo/Cairo-1.107.0-r1.ebuild
new file mode 100644
index 000000000000..37c59892cafe
--- /dev/null
+++ b/dev-perl/Cairo/Cairo-1.107.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=XAOC
+DIST_VERSION=1.107
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Perl interface to the cairo library"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=x11-libs/cairo-1.0.0
+"
+DEPEND="
+ >=x11-libs/cairo-1.0.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/ExtUtils-Depends-0.200.0
+ >=dev-perl/ExtUtils-PkgConfig-1.0.0
+ test? (
+ dev-perl/Test-Number-Delta
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.107-fatal-exit.patch"
+)
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}