summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-04 00:12:49 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-04 00:13:18 +1300
commit921fa13818ecb27fad798ee977c83658718daece (patch)
tree1aa0e4080ab3b0a871f3f0ef5af2cb2e549a857d /dev-perl/Carp-Assert-More
parentwww-client/firefox: stable 52.4.0 for ppc64, bug #632400 (diff)
downloadgentoo-921fa13818ecb27fad798ee977c83658718daece.tar.gz
gentoo-921fa13818ecb27fad798ee977c83658718daece.tar.bz2
gentoo-921fa13818ecb27fad798ee977c83658718daece.zip
dev-perl/Carp-Assert-More: Bump to version 1.160.0
- EAPI6 - Parallel Tests - Do prototypal compile test Upstream: - Add many new assert functions - Rename assert_listref to assert_arrayref (+compat) Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Carp-Assert-More')
-rw-r--r--dev-perl/Carp-Assert-More/Carp-Assert-More-1.160.0.ebuild34
-rw-r--r--dev-perl/Carp-Assert-More/Manifest1
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Carp-Assert-More/Carp-Assert-More-1.160.0.ebuild b/dev-perl/Carp-Assert-More/Carp-Assert-More-1.160.0.ebuild
new file mode 100644
index 000000000000..7202b242610b
--- /dev/null
+++ b/dev-perl/Carp-Assert-More/Carp-Assert-More-1.160.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PETDANCE
+DIST_VERSION=1.16
+inherit perl-module
+
+DESCRIPTION="convenience wrappers around Carp::Assert"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Carp-Assert
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Test-Exception )"
+
+src_test() {
+ perl_rm_files t/pod-coverage.t t/pod.t
+ perl-module_src_test
+ local MODULES=(
+ "Carp::Assert::More ${DIST_VERSION}"
+ )
+ for dep in "${MODULES[@]}"; do
+ perl -Mblib="${S}" -M"${dep} ()" -e1 ||
+ die "Could not load ${dep}"
+ done
+}
diff --git a/dev-perl/Carp-Assert-More/Manifest b/dev-perl/Carp-Assert-More/Manifest
index 5652a7d4c83e..64d2addf5d59 100644
--- a/dev-perl/Carp-Assert-More/Manifest
+++ b/dev-perl/Carp-Assert-More/Manifest
@@ -1 +1,2 @@
DIST Carp-Assert-More-1.14.tar.gz 10304 SHA256 3f004cbfa53476d85ab604a1e09fc4a5d7b28898c52f9549bd17c385c9c40733 SHA512 0411908afd5cc45cedce83fb10e67f78f7513fa788421d9c4e0f0f0064bf6fdd7154c2414a449456ff4c600f31eba138fb4d3f94e68743af4b71f7368c30b398 WHIRLPOOL 747a1ddf1bd8973a7ebbeb3a673aae00a182969291f1a946597e801afc5dab1237c5b13c28f46297bd43d44b904929faf552d8337a9965f040f31d4d51827452
+DIST Carp-Assert-More-1.16.tar.gz 12290 SHA256 8ed01cdd95715c41b690ed3add4f121f5161b0fae09dff8cb227613ab46932f5 SHA512 9f81604574eab5a0a5003ad747ffec3a3dd33bc63e67d12697e4e30de8cb234a73e225f82a4d0f31576e19382cc2d6a402962f5fe1e4c5289e080ca23b30c0fe WHIRLPOOL e95875e85281a8e3cd3448cc842c9e6f49be1863e0e66b5b76f45c5603c861423d465defaa3080c5a15c630a45309ff397c8669f974328971524e776a25bd24a