summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-05-02 15:21:45 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-05-02 15:30:25 +0200
commiteb288d9ddaa8e35c374a65f2e48ef18ac1847bb8 (patch)
treec27d3e53f5588e61361c766aafcc961410a57771 /dev-perl/Class-C3/Class-C3-0.350.0.ebuild
parentdev-util/oprofile: update jdk version requirement (diff)
downloadgentoo-eb288d9ddaa8e35c374a65f2e48ef18ac1847bb8.tar.gz
gentoo-eb288d9ddaa8e35c374a65f2e48ef18ac1847bb8.tar.bz2
gentoo-eb288d9ddaa8e35c374a65f2e48ef18ac1847bb8.zip
dev-perl/Class-C3: Version bump 0.35
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Class-C3/Class-C3-0.350.0.ebuild')
-rw-r--r--dev-perl/Class-C3/Class-C3-0.350.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/Class-C3/Class-C3-0.350.0.ebuild b/dev-perl/Class-C3/Class-C3-0.350.0.ebuild
new file mode 100644
index 000000000000..b864bd72a2d2
--- /dev/null
+++ b/dev-perl/Class-C3/Class-C3-0.350.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=HAARG
+DIST_VERSION=0.35
+inherit perl-module
+
+DESCRIPTION="A pragma to use the C3 method resolution order algortihm"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Note: https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/dev-perl/Class-C3#Bundling
+RDEPEND="
+ >=dev-perl/Algorithm-C3-0.70.0
+ virtual/perl-Scalar-List-Utils
+"
+
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.470.0
+ )
+"