summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-19 10:35:05 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-19 10:39:07 +1300
commit04291b6956a571e8e9191274dd20db4027f8d15d (patch)
tree0d304ec8daa4c86d894e30387deb0c6d0474d4f4 /dev-perl/Clipboard
parentdev-perl/Class-Factory-Util: EAPI6 + Tests (diff)
downloadgentoo-04291b6956a571e8e9191274dd20db4027f8d15d.tar.gz
gentoo-04291b6956a571e8e9191274dd20db4027f8d15d.tar.bz2
gentoo-04291b6956a571e8e9191274dd20db4027f8d15d.zip
dev-perl/Clipboard: EAPI6 + Tests
- EAPI6 - Enable tests - Fix virtualx needed for tests - Fix tests broken by '.' in @INC - Migrate makefile.PL fix to general '.' in @INC patch Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Clipboard')
-rw-r--r--dev-perl/Clipboard/Clipboard-0.130.0-r3.ebuild26
-rw-r--r--dev-perl/Clipboard/files/Clipboard-0.130.0-no-dot-inc.patch45
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-perl/Clipboard/Clipboard-0.130.0-r3.ebuild b/dev-perl/Clipboard/Clipboard-0.130.0-r3.ebuild
new file mode 100644
index 000000000000..1b02d004d0b7
--- /dev/null
+++ b/dev-perl/Clipboard/Clipboard-0.130.0-r3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=KING
+DIST_VERSION=0.13
+inherit perl-module virtualx
+
+DESCRIPTION="Copy and paste with any OS"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+# See bug 521890.
+PATCHES=(
+ "${FILESDIR}"/"${P}"-insecure-tempfile.patch
+ "${FILESDIR}"/"${P}"-no-dot-inc.patch
+)
+
+RDEPEND="x11-misc/xclip"
+
+src_test() {
+ virtx perl-module_src_test
+}
diff --git a/dev-perl/Clipboard/files/Clipboard-0.130.0-no-dot-inc.patch b/dev-perl/Clipboard/files/Clipboard-0.130.0-no-dot-inc.patch
new file mode 100644
index 000000000000..1e9c31be70e9
--- /dev/null
+++ b/dev-perl/Clipboard/files/Clipboard-0.130.0-no-dot-inc.patch
@@ -0,0 +1,45 @@
+From 389b272f8696b86f594726544a8280e43cd2ffc6 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Thu, 19 Oct 2017 10:21:36 +1300
+Subject: Fix Makefile.PL & Tests for '.' in @INC removal under Perl 5.26+
+
+Bug: https://bugs.gentoo.org/615138
+Bug: https://rt.cpan.org/Ticket/Display.html?id=121056
+---
+ Makefile.PL | 1 +
+ t/drivers.t | 2 ++
+ t/mock.t | 2 ++
+ 3 files changed, 5 insertions(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 08468ac..ab60784 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,3 +1,4 @@
++use lib '.';
+ use inc::Module::Install;
+ name('Clipboard');
+ author('Ryan King <rking@panoptic.com>');
+diff --git a/t/drivers.t b/t/drivers.t
+index 1ae7014..de2478f 100644
+--- a/t/drivers.t
++++ b/t/drivers.t
+@@ -1,3 +1,5 @@
++use File::Spec::Functions qw(rel2abs);
++use lib rel2abs('.');
+ use Test::Clipboard;
+ use strict; # XXX make Test::Clipboard do this
+ my %map = qw(
+diff --git a/t/mock.t b/t/mock.t
+index fbd76f0..2a50ebb 100644
+--- a/t/mock.t
++++ b/t/mock.t
+@@ -1,3 +1,5 @@
++use File::Spec::Functions qw(rel2abs);
++use lib rel2abs('.');
+ use Test::Clipboard;
+ use Test::MockClipboard;
+ use strict; # XXX make Test::Clipboard do this
+--
+2.14.2
+