summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Config-Properties
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Config-Properties')
-rw-r--r--dev-perl/Config-Properties/Config-Properties-1.770.0.ebuild25
-rw-r--r--dev-perl/Config-Properties/Config-Properties-1.800.0.ebuild26
-rw-r--r--dev-perl/Config-Properties/Manifest2
-rw-r--r--dev-perl/Config-Properties/metadata.xml9
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-perl/Config-Properties/Config-Properties-1.770.0.ebuild b/dev-perl/Config-Properties/Config-Properties-1.770.0.ebuild
new file mode 100644
index 000000000000..b78c11d15a0a
--- /dev/null
+++ b/dev-perl/Config-Properties/Config-Properties-1.770.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=SALVA
+MODULE_VERSION=1.77
+inherit perl-module
+
+DESCRIPTION="Configuration using Java style properties"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-File-Temp
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+
+SRC_TEST=do
diff --git a/dev-perl/Config-Properties/Config-Properties-1.800.0.ebuild b/dev-perl/Config-Properties/Config-Properties-1.800.0.ebuild
new file mode 100644
index 000000000000..6f1a2d28a669
--- /dev/null
+++ b/dev-perl/Config-Properties/Config-Properties-1.800.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=SALVA
+MODULE_VERSION=1.80
+inherit perl-module
+
+DESCRIPTION="Configuration using Java style properties"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-File-Temp
+ >=virtual/perl-Text-Tabs+Wrap-2001.92.900
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Config-Properties/Manifest b/dev-perl/Config-Properties/Manifest
new file mode 100644
index 000000000000..d22b25dbea20
--- /dev/null
+++ b/dev-perl/Config-Properties/Manifest
@@ -0,0 +1,2 @@
+DIST Config-Properties-1.77.tar.gz 13381 SHA256 59ec0f83882fac9df0b09d7cb13f5d094409eff9a5b29f1a911b9bb9962d915c SHA512 aad8b3799bb34cf058c933d470d823c2d52bb1bee1a560fd72d64d8e2f5795509c6b993618086998079782925c2140001c91d4acf90123eebda60c25881342a9 WHIRLPOOL 0c89e1a15c3b8739356f4a02ed94a9df5dae545c92af55a5c6c17b41309e23244f340dcec16686913c5923e4b12e32f1e7536dd677f1fe05150efa2704874812
+DIST Config-Properties-1.80.tar.gz 14204 SHA256 5d04395be7e14e970a03ea952fb7629ae304d97c031f90cc1c29bd0a6a62fc40 SHA512 2a3512aebeae2a95815dcd4cb84476919cf1aee5d5e8d93916d64ade3d49adc0720808487bba80664ccb978914b275f163cecbd5080075fd1f8f4d37697610bb WHIRLPOOL 1a79307d58d7a1543257f01db81d7ede2b1a6592a171f5e6763d8985b87d182295632745e0402cdc81ca284619e320a850b1390c15860eafb07e45211a45b6f4
diff --git a/dev-perl/Config-Properties/metadata.xml b/dev-perl/Config-Properties/metadata.xml
new file mode 100644
index 000000000000..a34dadf2454a
--- /dev/null
+++ b/dev-perl/Config-Properties/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Config-Properties</remote-id>
+ <remote-id type="cpan-module">Config::Properties</remote-id>
+ </upstream>
+</pkgmetadata>