summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-06-29 02:37:02 +1200
committerKent Fredric <kentnl@gentoo.org>2020-06-29 02:37:32 +1200
commite7cfff10f6cfcad1643a2a834b3d569311716241 (patch)
tree205424c111b5b994a82fa9550206833355120528 /dev-perl/Const-Fast/Const-Fast-0.14.0-r2.ebuild
parentx11-wm/mutter: x86 stable (bug #728924) (diff)
downloadgentoo-e7cfff10f6cfcad1643a2a834b3d569311716241.tar.gz
gentoo-e7cfff10f6cfcad1643a2a834b3d569311716241.tar.bz2
gentoo-e7cfff10f6cfcad1643a2a834b3d569311716241.zip
dev-perl/Const-Fast: -r bump for EAPI7
- EAPI7 - Remove unneeded variable assignments Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Const-Fast/Const-Fast-0.14.0-r2.ebuild')
-rw-r--r--dev-perl/Const-Fast/Const-Fast-0.14.0-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Const-Fast/Const-Fast-0.14.0-r2.ebuild b/dev-perl/Const-Fast/Const-Fast-0.14.0-r2.ebuild
new file mode 100644
index 000000000000..27a9d59ba25f
--- /dev/null
+++ b/dev-perl/Const-Fast/Const-Fast-0.14.0-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=LEONT
+DIST_VERSION=0.014
+inherit perl-module
+
+DESCRIPTION="Facility for creating read-only scalars, arrays, and hashes"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Storable
+ >=dev-perl/Sub-Exporter-Progressive-0.1.7
+"
+DEPEND="
+ dev-perl/Module-Build-Tiny
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-Tiny-0.21.0
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Temp
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"