summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-06-29 23:18:47 +1200
committerKent Fredric <kentnl@gentoo.org>2020-06-29 23:34:14 +1200
commit6704cb64c133cc255f4ddd704e4dc42c814cc84b (patch)
tree7cd8fe7483f27347f7f2846d8db9eb3a840603c4 /dev-perl/Cookie-Baker-XS
parentsys-apps/iucode_tool: drop old (diff)
downloadgentoo-6704cb64c133cc255f4ddd704e4dc42c814cc84b.tar.gz
gentoo-6704cb64c133cc255f4ddd704e4dc42c814cc84b.tar.bz2
gentoo-6704cb64c133cc255f4ddd704e4dc42c814cc84b.zip
dev-perl/Cookie-Baker-XS: Bump to version 0.110.0
- EAPI7 - Pass CFLAGS through to make Upstream: - Bump the version for no reason other than they've made it so all versions of dev-perl/Cookie-Baker require the XS version to be at least, the same version, even when there's no code changes in the XS version. Bug: https://github.com/kazeburo/Cookie-Baker/issues/17 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Cookie-Baker-XS')
-rw-r--r--dev-perl/Cookie-Baker-XS/Cookie-Baker-XS-0.110.0.ebuild30
-rw-r--r--dev-perl/Cookie-Baker-XS/Manifest1
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Cookie-Baker-XS/Cookie-Baker-XS-0.110.0.ebuild b/dev-perl/Cookie-Baker-XS/Cookie-Baker-XS-0.110.0.ebuild
new file mode 100644
index 000000000000..1fbe05d444dd
--- /dev/null
+++ b/dev-perl/Cookie-Baker-XS/Cookie-Baker-XS-0.110.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=KAZEBURO
+DIST_VERSION=0.11
+inherit perl-module
+
+DESCRIPTION="Accelerate Cookie::Baker's crush_cookie"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Exporter
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ test? (
+ >=virtual/perl-Test-Simple-0.980.0
+ )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
diff --git a/dev-perl/Cookie-Baker-XS/Manifest b/dev-perl/Cookie-Baker-XS/Manifest
index 6c181b5a3e87..46c849d364cf 100644
--- a/dev-perl/Cookie-Baker-XS/Manifest
+++ b/dev-perl/Cookie-Baker-XS/Manifest
@@ -1 +1,2 @@
DIST Cookie-Baker-XS-0.08.tar.gz 56729 BLAKE2B 040688d8b0d519a40833cb99b0601e1b591f7db33c63673f0acebea8c2228fb3e2b5f2cb32a7dbd2e793a61203af3a232c67f7df6d0acf99664b183fe4c4d7ad SHA512 ac51a13f0cedb329b15abefd4f4eefd6f40729f0dcc0458154ddba30fff53e9b5ae994a8d6051c1da2105c0901480c22ae99845d46a7fc5ba980cc447f98ee34
+DIST Cookie-Baker-XS-0.11.tar.gz 56814 BLAKE2B a62fafe4c5ec0a789865737440c08769b66fd5de637806ffee6f39be3810db21ab141c37709f416e1a3e140b931d05df8296236ecbaa7b676d6481a83319f3d8 SHA512 01c75cb2bd9163cc2e27bf5343a9bc7c596158ca57f93437307ee3a0d991ecc5c1c24e26c3e2a1116e5685fc5b6aacf17d09f22bba99919acd3df55964be762f