summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-01 11:20:13 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-01 11:21:12 +1200
commit01793cf31060c68d178d5d5e6d26eafcbc30e15b (patch)
treedc556317a714fc4a645da706a4488c7dd77053b1 /dev-perl/Crypt-DSA
parentprofiles/package.mask: propka 3.2 is py3 package (diff)
downloadgentoo-01793cf31060c68d178d5d5e6d26eafcbc30e15b.tar.gz
gentoo-01793cf31060c68d178d5d5e6d26eafcbc30e15b.tar.bz2
gentoo-01793cf31060c68d178d5d5e6d26eafcbc30e15b.zip
dev-perl/Crypt-DSA: -r bump for EAPI7 and fixes
- EAPI7 - Parallel tests - Improve dependencies to satisfy more tests - Migrate "sed" to "patch" Keywords: - Dropped ~sparc due to new test dependency dev-perl/Convert-PEM Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Crypt-DSA')
-rw-r--r--dev-perl/Crypt-DSA/Crypt-DSA-1.170.0-r1.ebuild35
-rw-r--r--dev-perl/Crypt-DSA/files/Crypt-DSA-1.17-no-dot-inc.patch21
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-perl/Crypt-DSA/Crypt-DSA-1.170.0-r1.ebuild b/dev-perl/Crypt-DSA/Crypt-DSA-1.170.0-r1.ebuild
new file mode 100644
index 000000000000..55bac478b237
--- /dev/null
+++ b/dev-perl/Crypt-DSA/Crypt-DSA-1.170.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ADAMK
+DIST_VERSION=1.17
+inherit perl-module
+
+DESCRIPTION="DSA Signatures and Key Generation"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~x86 ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-perl/Data-Buffer-0.10.0
+ dev-perl/Digest-SHA1
+ virtual/perl-File-Spec
+ >=dev-perl/File-Which-0.50.0
+ virtual/perl-MIME-Base64
+ >=virtual/perl-Math-BigInt-1.780.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.420.0
+ test? (
+ dev-perl/Convert-PEM
+ dev-perl/Math-BigInt-GMP
+ >=virtual/perl-Test-Simple-0.420.0
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.17-no-dot-inc.patch"
+)
diff --git a/dev-perl/Crypt-DSA/files/Crypt-DSA-1.17-no-dot-inc.patch b/dev-perl/Crypt-DSA/files/Crypt-DSA-1.17-no-dot-inc.patch
new file mode 100644
index 000000000000..5f0012ec33fc
--- /dev/null
+++ b/dev-perl/Crypt-DSA/files/Crypt-DSA-1.17-no-dot-inc.patch
@@ -0,0 +1,21 @@
+From 0e063bbea153b923ed0997e2990a2f30ef48c71f Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Wed, 1 Jul 2020 10:59:21 +1200
+Subject: Include '.' in @INC for perl 5.26+
+
+---
+ Makefile.PL | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index f29461b..0d015e9 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,3 +1,4 @@
++use lib '.';
+ use inc::Module::Install 1.01;
+
+ all_from 'lib/Crypt/DSA.pm';
+--
+2.27.0
+