summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-02 20:02:15 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-02 20:02:15 +1200
commitf00b07632126df10278f0f542d0475096fc8fda2 (patch)
treec8ab5b3208c3a12eea01d8fbc23edfd9cbded147 /dev-perl/Crypt-RIPEMD160
parentdev-perl/Crypt-RC4: -r + renorm version for EAPI7 (diff)
downloadgentoo-f00b07632126df10278f0f542d0475096fc8fda2.tar.gz
gentoo-f00b07632126df10278f0f542d0475096fc8fda2.tar.bz2
gentoo-f00b07632126df10278f0f542d0475096fc8fda2.zip
dev-perl/Crypt-RIPEMD160: -r bump for EAPI7 + CFLAGS love
- EAPI7 - Ensure CFLAGS passed to make/compile - Remove unused/empty variable assignment Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Crypt-RIPEMD160')
-rw-r--r--dev-perl/Crypt-RIPEMD160/Crypt-RIPEMD160-0.60.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/Crypt-RIPEMD160/Crypt-RIPEMD160-0.60.0-r1.ebuild b/dev-perl/Crypt-RIPEMD160/Crypt-RIPEMD160-0.60.0-r1.ebuild
new file mode 100644
index 000000000000..4efb9c207604
--- /dev/null
+++ b/dev-perl/Crypt-RIPEMD160/Crypt-RIPEMD160-0.60.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=TODDR
+DIST_VERSION=0.06
+inherit perl-module
+
+DESCRIPTION="Perl extension for the RIPEMD-160 Hash function"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}