summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2016-03-21 23:19:22 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-03-21 23:39:25 +0100
commitd4b6273a7404bc13344f91a98345fe1c74148146 (patch)
treef7eebdfa215568afeed64915dbf243203a1de674 /dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r2.ebuild
parentdev-ruby/cocaine: Remove old (diff)
downloadgentoo-d4b6273a7404bc13344f91a98345fe1c74148146.tar.gz
gentoo-d4b6273a7404bc13344f91a98345fe1c74148146.tar.bz2
gentoo-d4b6273a7404bc13344f91a98345fe1c74148146.zip
dev-perl/Crypt-SSLeay: Add version compatible with libressl-2.3 (no SSL2, no SSL3)
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r2.ebuild')
-rw-r--r--dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r2.ebuild b/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r2.ebuild
new file mode 100644
index 000000000000..a1b178abc688
--- /dev/null
+++ b/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=NANIS
+DIST_VERSION=0.72
+inherit perl-module
+
+DESCRIPTION="OpenSSL support for LWP"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="libressl test"
+
+RDEPEND="
+ !libressl? ( >=dev-libs/openssl-0.9.7c:0= )
+ libressl? ( dev-libs/libressl:0= )
+ virtual/perl-MIME-Base64
+"
+
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=virtual/perl-ExtUtils-CBuilder-0.280.205
+ virtual/perl-Getopt-Long
+ >=dev-perl/Path-Class-0.260.0
+ >=dev-perl/Try-Tiny-0.190.0
+ test? (
+ >=virtual/perl-Test-Simple-0.190.0
+ )
+"
+# PDEPEND: circular dependencies bug #144761
+PDEPEND="
+ dev-perl/libwww-perl
+ >=dev-perl/LWP-Protocol-https-6.20.0
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.720.0-no-ssl3.patch )