summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-04-06 20:20:43 +1200
committerKent Fredric <kentnl@gentoo.org>2017-04-06 20:37:49 +1200
commit2e6c165ffbfd8b6a45f10c4703bb19a546d547ba (patch)
tree333913a6e784f906dc8f454e9c0d45ffcc895414 /dev-perl/CryptX/CryptX-0.47.0.ebuild
parentdev-perl/Crypt-Curve25519: Bump to version 0.60.0 (diff)
downloadgentoo-2e6c165ffbfd8b6a45f10c4703bb19a546d547ba.tar.gz
gentoo-2e6c165ffbfd8b6a45f10c4703bb19a546d547ba.tar.bz2
gentoo-2e6c165ffbfd8b6a45f10c4703bb19a546d547ba.zip
dev-perl/CryptX: Bump to version 0.47.0
Upstream: - Compiler-agnostic approach to fixing lto issues - Fix build failures on bsd with features needing newer binutils Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-perl/CryptX/CryptX-0.47.0.ebuild')
-rw-r--r--dev-perl/CryptX/CryptX-0.47.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/CryptX/CryptX-0.47.0.ebuild b/dev-perl/CryptX/CryptX-0.47.0.ebuild
new file mode 100644
index 000000000000..0f51915f8e17
--- /dev/null
+++ b/dev-perl/CryptX/CryptX-0.47.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+DIST_AUTHOR=MIK
+DIST_VERSION=0.047
+inherit perl-module
+
+DESCRIPTION="Self-contained crypto toolkit"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test minimal"
+
+RDEPEND="
+ >=virtual/perl-Exporter-5.590.0
+ !minimal? (
+ || ( dev-perl/JSON-XS virtual/perl-JSON-PP )
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.880.0
+ !minimal? (
+ >=virtual/perl-Math-BigInt-1.999.715
+ >=virtual/perl-Storable-2.0.0
+ )
+ )
+"
+
+src_test() {
+ perl_rm_files t/003_all_pm_pod.t
+ perl-module_src_test
+}