summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-08-17 16:27:06 +0200
committerKent Fredric <kentnl@gentoo.org>2019-08-29 21:40:44 +1200
commit945eb72e9fd616d936f29d8d77f03c077a787ad4 (patch)
tree57b27ef95348fb141f4692fecaf3d59c7ab754c1 /dev-perl/DBD-mysql/DBD-mysql-4.50.0.ebuild
parentprofiles: package.use.stable.mask DBD-mysql USE=mariadb (diff)
downloadgentoo-945eb72e9fd616d936f29d8d77f03c077a787ad4.tar.gz
gentoo-945eb72e9fd616d936f29d8d77f03c077a787ad4.tar.bz2
gentoo-945eb72e9fd616d936f29d8d77f03c077a787ad4.zip
dev-perl/DBD-mysql: bump to v4.050
Closes: https://bugs.gentoo.org/661480 Closes: https://github.com/gentoo/gentoo/pull/12731 Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org> Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/DBD-mysql/DBD-mysql-4.50.0.ebuild')
-rw-r--r--dev-perl/DBD-mysql/DBD-mysql-4.50.0.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/dev-perl/DBD-mysql/DBD-mysql-4.50.0.ebuild b/dev-perl/DBD-mysql/DBD-mysql-4.50.0.ebuild
new file mode 100644
index 000000000000..4f268c86e07d
--- /dev/null
+++ b/dev-perl/DBD-mysql/DBD-mysql-4.50.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DVEEDEN
+DIST_VERSION=4.050
+inherit eutils perl-module
+
+DESCRIPTION="MySQL driver for the Perl5 Database Interface (DBI)"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="mariadb +mysql test +ssl"
+REQUIRED_USE="^^ ( mysql mariadb )"
+
+RDEPEND=">=dev-perl/DBI-1.609.0
+ >=dev-perl/Devel-CheckLib-1.109.0
+ mysql? ( dev-db/mysql-connector-c:= )
+ mariadb? ( dev-db/mariadb-connector-c:=[ssl(+)?] )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/perl-Data-Dumper
+ test? (
+ dev-perl/Test-Deep
+ >=virtual/perl-Test-Simple-0.900.0
+ virtual/perl-Time-HiRes
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-${DIST_VERSION}-no-dot-inc.patch"
+ "${FILESDIR}/${PN}-${DIST_VERSION}-fix-float-type-conversion.patch"
+ "${FILESDIR}/${PN}-${DIST_VERSION}-fix-for-MariaDB-10.3.13-with-zerofil.patch"
+)
+
+src_configure() {
+ local impl
+ impl=$(usex mariadb mariadb mysql)
+ if use test; then
+ myconf="${myconf} --testdb=test \
+ --testhost=localhost \
+ --testuser=test \
+ --testpassword=test"
+ fi
+ myconf="${myconf} --$(usex ssl ssl nossl) --mysql_config=${EPREFIX%/}/usr/bin/${impl}_config"
+ perl-module_src_configure
+}
+
+# Parallel testing is broken as 2 tests create the same table
+# and mysql isn't acid compliant and can't limit visibility of tables
+# to a transaction...
+DIST_TEST="do"
+
+src_test() {
+ einfo
+ einfo "If tests fail, you have to configure your MySQL instance to create"
+ einfo "and grant some privileges to the test user."
+ einfo "You can run the following commands at the MySQL prompt: "
+ einfo "> CREATE USER 'test'@'localhost' IDENTIFIED BY 'test';"
+ einfo "> CREATE DATABASE test;"
+ einfo "> GRANT ALL PRIVILEGES ON test.* TO 'test'@'localhost';"
+ einfo
+ sleep 5
+ perl_rm_files t/pod.t t/manifest.t
+ # Don't be a hero and try to do EXTENDED_TESTING=1 unless you can figure
+ # out why 60leaks.t fails
+ perl-module_src_test
+}