summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-06-25 21:37:32 +1200
committerKent Fredric <kentnl@gentoo.org>2017-06-25 21:37:32 +1200
commit4b1d4f9eb5de2a46584b94c611127b968aa58750 (patch)
tree2808700bad624981b7f8af235ace747b2b24b629 /dev-perl/DBICx-TestDatabase
parentdev-perl/SQL-Translator: Fix for '.' in @INC re bug #615708 (diff)
downloadgentoo-4b1d4f9eb5de2a46584b94c611127b968aa58750.tar.gz
gentoo-4b1d4f9eb5de2a46584b94c611127b968aa58750.tar.bz2
gentoo-4b1d4f9eb5de2a46584b94c611127b968aa58750.zip
dev-perl/DBICx-TestDatabase: Fix for '.' in @INC re bug #615712
Generic Module::Install + 5.26 fix Bug: https://bugs.gentoo.org/615712 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-perl/DBICx-TestDatabase')
-rw-r--r--dev-perl/DBICx-TestDatabase/DBICx-TestDatabase-0.40.0.ebuild8
-rw-r--r--dev-perl/DBICx-TestDatabase/DBICx-TestDatabase-0.50.0.ebuild8
2 files changed, 14 insertions, 2 deletions
diff --git a/dev-perl/DBICx-TestDatabase/DBICx-TestDatabase-0.40.0.ebuild b/dev-perl/DBICx-TestDatabase/DBICx-TestDatabase-0.40.0.ebuild
index f3433e222efd..fde967d26958 100644
--- a/dev-perl/DBICx-TestDatabase/DBICx-TestDatabase-0.40.0.ebuild
+++ b/dev-perl/DBICx-TestDatabase/DBICx-TestDatabase-0.40.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -26,3 +26,9 @@ DEPEND="${RDEPEND}
"
SRC_TEST="do"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install;/use lib q[.];\nuse inc::Module::Install;/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}
diff --git a/dev-perl/DBICx-TestDatabase/DBICx-TestDatabase-0.50.0.ebuild b/dev-perl/DBICx-TestDatabase/DBICx-TestDatabase-0.50.0.ebuild
index cf49bbea0257..1e043da5e0f4 100644
--- a/dev-perl/DBICx-TestDatabase/DBICx-TestDatabase-0.50.0.ebuild
+++ b/dev-perl/DBICx-TestDatabase/DBICx-TestDatabase-0.50.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -25,3 +25,9 @@ DEPEND="${RDEPEND}
)
"
PERL_RM_FILES=("MYMETA.json" "MYMETA.yml") # https://rt.cpan.org/Ticket/Display.html?id=108141
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install;/use lib q[.];\nuse inc::Module::Install;/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}