summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-14 08:19:38 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-14 08:19:55 +1200
commit662a34beb8244945a97ee1c39c02a4849a2e5ab7 (patch)
tree4685178daf17ad447af614e2d3ab13e3c924d602 /dev-perl/DBIx-Class-UserStamp/DBIx-Class-UserStamp-0.110.0-r2.ebuild
parentnet-irc/irker: add Python 3.9 (diff)
downloadgentoo-662a34beb8244945a97ee1c39c02a4849a2e5ab7.tar.gz
gentoo-662a34beb8244945a97ee1c39c02a4849a2e5ab7.tar.bz2
gentoo-662a34beb8244945a97ee1c39c02a4849a2e5ab7.zip
dev-perl/DBIx-Class-UserStamp: -r bump for EAPI7 + fixes
- EAPI7 - Unconditionally patch out bad tests - Convert "sed" hack to a patch Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/DBIx-Class-UserStamp/DBIx-Class-UserStamp-0.110.0-r2.ebuild')
-rw-r--r--dev-perl/DBIx-Class-UserStamp/DBIx-Class-UserStamp-0.110.0-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/DBIx-Class-UserStamp/DBIx-Class-UserStamp-0.110.0-r2.ebuild b/dev-perl/DBIx-Class-UserStamp/DBIx-Class-UserStamp-0.110.0-r2.ebuild
new file mode 100644
index 000000000000..1701a8d1ee5a
--- /dev/null
+++ b/dev-perl/DBIx-Class-UserStamp/DBIx-Class-UserStamp-0.110.0-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=JGOULAH
+DIST_VERSION=0.11
+inherit perl-module
+
+DESCRIPTION="Automatically set update and create user id fields"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-perl/Class-Accessor-Grouped
+ dev-perl/DBIx-Class-DynamicDefault
+ dev-perl/DBIx-Class
+"
+BDEPEND="${RDEPEND}
+ test? ( dev-perl/DBD-SQLite )
+"
+PERL_RM_FILES=(
+ t/02pod.t
+ t/03podcoverage.t
+)
+PATCHES=(
+ "${FILESDIR}/${PN}-0.11-no-dot-inc.patch"
+)
+
+# Parallel tests fail sometimes due to sharing a sqlite db path
+# and recreating the same table
+DIST_TEST="do"