summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-14 09:21:52 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-14 09:21:52 +1200
commit5985fbcf68b441b9ac02113bd46b90ecbaf2f63d (patch)
tree9ae6bd75cd9061080cd848b64520158739dc18a4 /dev-perl/DBIx-Safe
parentdev-perl/DBIx-Migration: -r bump for EAPI7 (diff)
downloadgentoo-5985fbcf68b441b9ac02113bd46b90ecbaf2f63d.tar.gz
gentoo-5985fbcf68b441b9ac02113bd46b90ecbaf2f63d.tar.bz2
gentoo-5985fbcf68b441b9ac02113bd46b90ecbaf2f63d.zip
dev-perl/DBIx-Safe: -r bump for EAPI7 + fixes
- EAPI7 - Add license note - Unconditionally patch out bad tests - Improve testing ewarn message slightly for readability Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/DBIx-Safe')
-rw-r--r--dev-perl/DBIx-Safe/DBIx-Safe-1.2.5-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/DBIx-Safe/DBIx-Safe-1.2.5-r2.ebuild b/dev-perl/DBIx-Safe/DBIx-Safe-1.2.5-r2.ebuild
new file mode 100644
index 000000000000..e55917b9818f
--- /dev/null
+++ b/dev-perl/DBIx-Safe/DBIx-Safe-1.2.5-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=TURNSTEP
+DIST_VERSION=1.2.5
+inherit perl-module eutils
+
+DESCRIPTION="Safer access to your database through a DBI database handle"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# Note, may be incorrect:
+# https://bugs.gentoo.org/433601
+LICENSE="BSD-2"
+
+RDEPEND="
+ >=dev-perl/DBI-1.490.0
+ >=dev-perl/DBD-Pg-1.490.0
+"
+BDEPEND="${RDEPEND}"
+
+PERL_RM_FILES=(
+ t/02perlcritic.t
+)
+src_test() {
+ if [[ -z "${DBI_DSN}" ]]; then
+ ewarn "Comprehensive testing of this package requires some manual configuration."
+ ewarn "For details, see:"
+ ewarn " https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/${CATEGORY}/${PN}"
+ fi
+ perl-module_src_test
+}