summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-11-11 03:23:37 +1300
committerKent Fredric <kentnl@gentoo.org>2016-11-11 04:14:51 +1300
commita7ea13e2a629d7fdc89e1d926574d76c57837380 (patch)
tree3569d8e1efd4d29abd2aecd2b9ef9897d9c03167 /dev-perl/DB_File-Lock
parentdev-perl/DBIx-SearchBuilder: Remove POD Authortest (diff)
downloadgentoo-a7ea13e2a629d7fdc89e1d926574d76c57837380.tar.gz
gentoo-a7ea13e2a629d7fdc89e1d926574d76c57837380.tar.bz2
gentoo-a7ea13e2a629d7fdc89e1d926574d76c57837380.zip
dev-perl/DB_File-Lock: Fix test failure on perl >5.20
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-perl/DB_File-Lock')
-rw-r--r--dev-perl/DB_File-Lock/DB_File-Lock-0.50.0-r1.ebuild4
-rw-r--r--dev-perl/DB_File-Lock/files/DB_File-Lock-0.05-RT98224.patch29
2 files changed, 32 insertions, 1 deletions
diff --git a/dev-perl/DB_File-Lock/DB_File-Lock-0.50.0-r1.ebuild b/dev-perl/DB_File-Lock/DB_File-Lock-0.50.0-r1.ebuild
index 0ad4cc422f48..0f9649b7ea44 100644
--- a/dev-perl/DB_File-Lock/DB_File-Lock-0.50.0-r1.ebuild
+++ b/dev-perl/DB_File-Lock/DB_File-Lock-0.50.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -17,4 +17,6 @@ IUSE=""
RDEPEND="virtual/perl-DB_File"
DEPEND="${RDEPEND}"
+PATCHES=("${FILESDIR}/${PN}-${MODULE_VERSION}-RT98224.patch")
+
SRC_TEST=do
diff --git a/dev-perl/DB_File-Lock/files/DB_File-Lock-0.05-RT98224.patch b/dev-perl/DB_File-Lock/files/DB_File-Lock-0.05-RT98224.patch
new file mode 100644
index 000000000000..6826dafb5d60
--- /dev/null
+++ b/dev-perl/DB_File-Lock/files/DB_File-Lock-0.05-RT98224.patch
@@ -0,0 +1,29 @@
+From 247a7ec3a57f2bca977531281f258d5e4ed46c1f Mon Sep 17 00:00:00 2001
+From: Slaven Rezic <slaven@rezic.de>
+Date: Thu, 21 Aug 2014 19:54:41 +0200
+Subject: [PATCH] don't use defined %hash
+
+This fixes https://rt.cpan.org/Ticket/Display.html?id=98224
+---
+ test.pl | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+ mode change 100644 => 100755 test.pl
+
+diff --git a/test.pl b/test.pl
+old mode 100644
+new mode 100755
+index 92ebcf6..cba6da6
+--- a/test.pl
++++ b/test.pl
+@@ -81,7 +81,7 @@ if ( not defined $pid ) {
+ sleep(1);
+ $TEST_NUM += 2;
+ report_result( not tie %hash3, 'DB_File::Lock', $file1, O_RDWR, 0600, $DB_HASH, $nonblock_write );
+- report_result( not defined %hash3 ); # double check and satisfy -w about %hash3
++ report_result( not keys %hash3 ); # double check and satisfy -w about %hash3
+ $TEST_NUM += 1;
+ report_result( wait() == $pid );
+ report_result( tie %hash3, 'DB_File::Lock', $file1, O_RDWR, 0600, $DB_HASH, $nonblock_write );
+--
+1.8.3.4
+