summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-10 03:48:48 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-10 03:51:41 +1300
commit09b633197c4b1e064dba28a34199f7b8af25247c (patch)
treeb1f6386202e62c88c7dec1127629b4f60a10ddf4 /dev-perl/Data-FormValidator
parentx11-libs/libfakekey: keyworded 0.1-r2 for ppc64, bug #633320 (thanks to ernst... (diff)
downloadgentoo-09b633197c4b1e064dba28a34199f7b8af25247c.tar.gz
gentoo-09b633197c4b1e064dba28a34199f7b8af25247c.tar.bz2
gentoo-09b633197c4b1e064dba28a34199f7b8af25247c.zip
dev-perl/Data-FormValidator: Bump to version 4.880.0
- Fix upstream installing spurious README.pod - Advertise optional test dependencies - Ensure all shipped modules compile Upstream: - Fixed '.' in @INC loading - Add support for 2-series mastercard numbers Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Data-FormValidator')
-rw-r--r--dev-perl/Data-FormValidator/Data-FormValidator-4.880.0.ebuild67
-rw-r--r--dev-perl/Data-FormValidator/Manifest1
-rw-r--r--dev-perl/Data-FormValidator/files/Data-FormValidator-4.880.0-skip-readme-pod.patch34
3 files changed, 102 insertions, 0 deletions
diff --git a/dev-perl/Data-FormValidator/Data-FormValidator-4.880.0.ebuild b/dev-perl/Data-FormValidator/Data-FormValidator-4.880.0.ebuild
new file mode 100644
index 000000000000..55615c0f9af3
--- /dev/null
+++ b/dev-perl/Data-FormValidator/Data-FormValidator-4.880.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DFARRELL
+DIST_VERSION=4.88
+inherit perl-module
+
+DESCRIPTION="Validates user input (usually from an HTML form) based on input profile"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-perl/Image-Size
+ >=dev-perl/Date-Calc-5.0
+ >=dev-perl/File-MMagic-1.170.0
+ >=dev-perl/MIME-Types-1.5.0
+ >=dev-perl/Regexp-Common-0.30.0
+ dev-perl/Email-Valid
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+PATCHES=( "${FILESDIR}/${P}-skip-readme-pod.patch" )
+src_test() {
+ local i;
+ elog "Install the following dependencies for comprehensive tests:"
+ i="$(if has_version '>=dev-perl/CGI-4.350.0'; then echo '[I]'; else echo '[ ]'; fi)"
+ elog " $i >=dev-perl/CGI-4.350.0"
+ elog " - Test interop with CGI.pm as an input source";
+ i="$(if has_version 'dev-perl/CGI-Simple'; then echo '[I]'; else echo '[ ]'; fi)"
+ elog " $i dev-perl/CGI-Simple"
+ elog " - Test interop with CGI::Simple as an input source";
+ i="$(if has_version 'dev-perl/Template-Toolkit'; then echo '[I]'; else echo '[ ]'; fi)"
+ elog " $i dev-perl/Template-Toolkit"
+ elog " - Test Template.pm can format Data::FormValidator objects";
+ elog
+ perl_rm_files t/pod.t
+ local MODULES=(
+ "Data::FormValidator ${DIST_VERSION}"
+ "Data::FormValidator::Constraints ${DIST_VERSION}"
+ "Data::FormValidator::Constraints::Dates ${DIST_VERSION}"
+ "Data::FormValidator::Constraints::Upload ${DIST_VERSION}"
+ "Data::FormValidator::ConstraintsFactory ${DIST_VERSION}"
+ "Data::FormValidator::Filters ${DIST_VERSION}"
+ "Data::FormValidator::Results ${DIST_VERSION}"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ perl-module_src_test
+}
diff --git a/dev-perl/Data-FormValidator/Manifest b/dev-perl/Data-FormValidator/Manifest
index 365fab8473ab..ee6104b076e1 100644
--- a/dev-perl/Data-FormValidator/Manifest
+++ b/dev-perl/Data-FormValidator/Manifest
@@ -1,3 +1,4 @@
DIST Data-FormValidator-4.81.tar.gz 109870 SHA256 f844056231b2eeb4068cafbcab1ddf5d46cb348bd5cfb1d234421c09ee8a0de3 SHA512 c9939686e60bb75e658a95407d616e7907f97e85d049d69abaf7ac89678985c555fe6d4177c773916c57964a45a423582e74d3cf79d75cef87a22f913ef82e23 WHIRLPOOL b730999ccfb945b102ecaf9cddeea2d64035b880ce82187410dbd16a8c7a09412299ea20cd7533d8edc485f7caa213ead21c0046ae9438191e8cd23b8e9d7bb3
DIST Data-FormValidator-4.85.tar.gz 99367 SHA256 809f15d05434ff5667c3967e71e86308fcfad8fce1057420bd2714300b2a5870 SHA512 6ccd119553f85728d01f57a1fb0a8b24241ea09d951dd761c52594302e687c33cdefbf37c2161ad02fca2363c530b7023185a0b75ba304ade6caed9d7faa77cb WHIRLPOOL d052a1d7b787086a5cc07fa1dfd1100463ad8184225e45f2915966a3b7b308cc08ce2bd860ae28d5ec0bfbb3d126b229fa3f1a2d909254239409b5df6beb6f0b
DIST Data-FormValidator-4.86.tar.gz 101409 SHA256 004fc21b95574402229f498b9cbdffc5c16a88302338dcc0b3b8091012cdc407 SHA512 ca9e178313dcc15006a0d5557494d50d9328ae4ae9b54428bfd76b3c6169767290f819c70af1928f772ce9a2cd2139eb373e69394af8f03eee0f061525bc76f4 WHIRLPOOL 5698cef0514e84a2004075b66f3eae9d58bcf67a54fec9a040f8045d4e9d31a3b06f4dcc0c0b6b1d079fce1a2d79a126103dd19486dfca0cff3f66f2b3cda3ba
+DIST Data-FormValidator-4.88.tar.gz 99850 SHA256 c1a539f91c92cbcd8a8d83597ec9a7643fcd8ccf5a94e15382c3765289170066 SHA512 f4f9d813a3c9ae3cefdc1795516c955307dbaa23ca464e5a0a31eb4a9f43a3f31da8155b911433d29915d65da5b05d0843b7de45287d977a0c58ba19f3cfc736 WHIRLPOOL 3bd800dc253abd03c19514560234bfc4c840a96e52d2f6dcacb516b41c6690481cf668ad2ce1ae7f8dca5aad426302eecd9e86d37194f009a84c149029428d9a
diff --git a/dev-perl/Data-FormValidator/files/Data-FormValidator-4.880.0-skip-readme-pod.patch b/dev-perl/Data-FormValidator/files/Data-FormValidator-4.880.0-skip-readme-pod.patch
new file mode 100644
index 000000000000..17cf910684f2
--- /dev/null
+++ b/dev-perl/Data-FormValidator/files/Data-FormValidator-4.880.0-skip-readme-pod.patch
@@ -0,0 +1,34 @@
+From f0afbb4d0d21cee2ef0497ca8205e375bf7eb19d Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Tue, 10 Oct 2017 03:23:55 +1300
+Subject: Prevent installing README.pod to final install
+
+This fixes the final "make install" so that matching regexed files do
+not get copied from blib/ to the OS
+
+Previously, a cruft file could be found in @INC by performing:
+
+ perldoc Data::README
+
+Which would give you the README.pod of Data::FormValidator
+
+This is a left-over artifact from the old days where this mechanism
+was The Way to install .pod/.pm files, and is still heavily used this
+way for .xs files.
+
+Bug: https://github.com/dnmfarrell/Data-FormValidator/pull/7
+---
+ INSTALL.SKIP | 1 +
+ 1 file changed, 1 insertion(+)
+ create mode 100644 INSTALL.SKIP
+
+diff --git a/INSTALL.SKIP b/INSTALL.SKIP
+new file mode 100644
+index 0000000..85828ef
+--- /dev/null
++++ b/INSTALL.SKIP
+@@ -0,0 +1 @@
++\bREADME\.pod$
+--
+2.14.1
+