summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-11-11 09:17:35 +1300
committerKent Fredric <kentnl@gentoo.org>2016-11-11 16:45:50 +1300
commit569e554df62c732347130b9e53e8f88d073b48ec (patch)
treebe0a457787b73a2b31abb2131710900f22040626 /dev-perl/Data-Validate-Domain/Data-Validate-Domain-0.140.0.ebuild
parentdev-perl/Test2-Suite: Add at 0.0.60 (masked) (diff)
downloadgentoo-569e554df62c732347130b9e53e8f88d073b48ec.tar.gz
gentoo-569e554df62c732347130b9e53e8f88d073b48ec.tar.bz2
gentoo-569e554df62c732347130b9e53e8f88d073b48ec.zip
dev-perl/Data-Validate-Domain: Bump to 0.140.0 ( Masked )
0.140.0 Requires a newer Test-Simple which is currently masked for rollout purposes - EAPI6 Upstream: - Accept absolute DNS names like "example.com." for domains and hosts - Added option domain_disable_tld_validation to permit "too new" TLD's to exist. - Require newer Net::Domain::TLD to maximise TLD coverage Keywording: - dropped ~hppa due to new dependency Test2-Suite Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-perl/Data-Validate-Domain/Data-Validate-Domain-0.140.0.ebuild')
-rw-r--r--dev-perl/Data-Validate-Domain/Data-Validate-Domain-0.140.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Data-Validate-Domain/Data-Validate-Domain-0.140.0.ebuild b/dev-perl/Data-Validate-Domain/Data-Validate-Domain-0.140.0.ebuild
new file mode 100644
index 000000000000..7078c302e740
--- /dev/null
+++ b/dev-perl/Data-Validate-Domain/Data-Validate-Domain-0.140.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=0.14
+
+inherit perl-module
+
+DESCRIPTION="Domain and host name validation"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Exporter
+ >=dev-perl/Net-Domain-TLD-1.740.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-1.302.15
+ dev-perl/Test2-Suite
+ )
+"