summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Date-Calc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Date-Calc')
-rw-r--r--dev-perl/Date-Calc/Date-Calc-6.300.0-r1.ebuild24
-rw-r--r--dev-perl/Date-Calc/Date-Calc-6.400.0.ebuild28
-rw-r--r--dev-perl/Date-Calc/Manifest2
-rw-r--r--dev-perl/Date-Calc/metadata.xml14
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-perl/Date-Calc/Date-Calc-6.300.0-r1.ebuild b/dev-perl/Date-Calc/Date-Calc-6.300.0-r1.ebuild
new file mode 100644
index 000000000000..103cce2379e0
--- /dev/null
+++ b/dev-perl/Date-Calc/Date-Calc-6.300.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=STBEY
+MODULE_VERSION=6.3
+inherit perl-module
+
+DESCRIPTION="Gregorian calendar date calculations"
+
+LICENSE="${LICENSE} LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=">=dev-perl/Bit-Vector-6.6
+ >=dev-perl/Carp-Clan-5.3"
+RDEPEND="${DEPEND}"
+
+SRC_TEST="do"
+export OPTIMIZE="$CFLAGS"
+mydoc="ToDo"
diff --git a/dev-perl/Date-Calc/Date-Calc-6.400.0.ebuild b/dev-perl/Date-Calc/Date-Calc-6.400.0.ebuild
new file mode 100644
index 000000000000..ebdb4018bb86
--- /dev/null
+++ b/dev-perl/Date-Calc/Date-Calc-6.400.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=STBEY
+MODULE_VERSION=6.4
+inherit perl-module
+
+DESCRIPTION="Gregorian calendar date calculations"
+
+LICENSE="${LICENSE} LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ >=dev-perl/Bit-Vector-7.400.0
+ >=dev-perl/Carp-Clan-6.40.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+SRC_TEST="do"
+export OPTIMIZE="$CFLAGS"
+mydoc="ToDo"
diff --git a/dev-perl/Date-Calc/Manifest b/dev-perl/Date-Calc/Manifest
new file mode 100644
index 000000000000..b270852fc0a5
--- /dev/null
+++ b/dev-perl/Date-Calc/Manifest
@@ -0,0 +1,2 @@
+DIST Date-Calc-6.3.tar.gz 168967 SHA256 3eb66188af89abc65b71e9852808d5d6b4bea7a606c55f2ae52c229bfc5bdb93 SHA512 74d755e07c2c1601b3f9ae630a60142367a8b6aa11223da57334b05b363fe636f2d77eeb5cce273122e1f090bc917c8b833370451a7a402637f29305523c2385 WHIRLPOOL 86db06898a947f4ea4e30835b465ed079c5f54e7637c948205e0e1ed4a2fd957bab7b88b7086d597ad64892f7096136fb8d5ef6ea8702a085cc1e88e42dba57e
+DIST Date-Calc-6.4.tar.gz 173828 SHA256 7ce137b2e797b7c0901f3adf1a05a19343356cd1f04676aa1c56a9f624f859ad SHA512 e2d0cb2b041afedb10033700e27075f01987abc763a59034a10a9fc0bb059706cc959f6d76fe1fc21ced4b547475f62a8c37ad38e8e49f7453d78b17082c0671 WHIRLPOOL adb18aa6e6f00b58f860830bd840add58516e28e326f165ff7f05e0ae1498e4d5f933654d7b3feb06f1babc27ff6130f7429019932af2c14df7a2577522f1dd6
diff --git a/dev-perl/Date-Calc/metadata.xml b/dev-perl/Date-Calc/metadata.xml
new file mode 100644
index 000000000000..8a1f2e2f273d
--- /dev/null
+++ b/dev-perl/Date-Calc/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Date-Calc</remote-id>
+ <remote-id type="cpan-module">Date::Calc</remote-id>
+ <remote-id type="cpan-module">Date::Calc::Object</remote-id>
+ <remote-id type="cpan-module">Date::Calc::PP</remote-id>
+ <remote-id type="cpan-module">Date::Calendar</remote-id>
+ <remote-id type="cpan-module">Date::Calendar::Profiles</remote-id>
+ <remote-id type="cpan-module">Date::Calendar::Year</remote-id>
+ </upstream>
+</pkgmetadata>