summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-12-12 04:50:32 +1300
committerKent Fredric <kentnl@gentoo.org>2016-12-12 04:51:01 +1300
commit9b3acb129ddd43523578b611734d4697fad45c43 (patch)
tree00d9ef98ac5ade29419a5d17ebb57a3b0aa63594 /dev-perl/DateTime-Format-Strptime/DateTime-Format-Strptime-1.700.0.ebuild
parentdev-perl/Net-IDN-Encode: Bump to version 2.303.0 (diff)
downloadgentoo-9b3acb129ddd43523578b611734d4697fad45c43.tar.gz
gentoo-9b3acb129ddd43523578b611734d4697fad45c43.tar.bz2
gentoo-9b3acb129ddd43523578b611734d4697fad45c43.zip
dev-perl/DateTime-Format-Strptime: Bump to version 1.700.0
Upstream: - Fix boundary check for parsing dd-mm-yy so it doesn't accidentally match yy[yy-mm-dd] as yy[dd-mm-yy] or match [dd-mm-yy]yy - Extend %z specifier to accept HH and HH:MM in addition to HHMM Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-perl/DateTime-Format-Strptime/DateTime-Format-Strptime-1.700.0.ebuild')
-rw-r--r--dev-perl/DateTime-Format-Strptime/DateTime-Format-Strptime-1.700.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/DateTime-Format-Strptime/DateTime-Format-Strptime-1.700.0.ebuild b/dev-perl/DateTime-Format-Strptime/DateTime-Format-Strptime-1.700.0.ebuild
new file mode 100644
index 000000000000..58222bde52e7
--- /dev/null
+++ b/dev-perl/DateTime-Format-Strptime/DateTime-Format-Strptime-1.700.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=1.70
+inherit perl-module
+
+DESCRIPTION="Parse and Format DateTimes using Strptime"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x64-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/DateTime-1
+ >=dev-perl/DateTime-Locale-0.450.0
+ >=dev-perl/DateTime-TimeZone-0.790.0
+ virtual/perl-Exporter
+ >=dev-perl/Package-DeprecationManager-0.150.0
+ >=dev-perl/Params-Validate-1.200.0
+ dev-perl/Try-Tiny
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.960.0
+ dev-perl/Test-Fatal
+ dev-perl/Test-Warnings
+ )
+"