summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-11-12 07:15:07 +1300
committerKent Fredric <kentnl@gentoo.org>2016-11-12 09:18:45 +1300
commit0d83694ef7d8409e445b65a75f6673032ca24b06 (patch)
tree617f871e173b0eddae577cdfbe32e7c056c4f33e /dev-perl/DateTime-Locale/DateTime-Locale-1.50.0.ebuild
parentperl-core/Test-Simple: Remove old (diff)
downloadgentoo-0d83694ef7d8409e445b65a75f6673032ca24b06.tar.gz
gentoo-0d83694ef7d8409e445b65a75f6673032ca24b06.tar.bz2
gentoo-0d83694ef7d8409e445b65a75f6673032ca24b06.zip
dev-perl/DateTime-Locale: Bump to 1.50.0
This version requires a newer Scalar-List-Util Upstream: - Replace List::MoreUtils with newer List::Util - Improve stability of loading Locale::Data from DATA handle by pre-caching all the raw data, at a cost of increased memory usage. Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-perl/DateTime-Locale/DateTime-Locale-1.50.0.ebuild')
-rw-r--r--dev-perl/DateTime-Locale/DateTime-Locale-1.50.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/DateTime-Locale/DateTime-Locale-1.50.0.ebuild b/dev-perl/DateTime-Locale/DateTime-Locale-1.50.0.ebuild
new file mode 100644
index 000000000000..9a08e8b1cb0a
--- /dev/null
+++ b/dev-perl/DateTime-Locale/DateTime-Locale-1.50.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=1.05
+DIST_EXAMPLES=("eg/*")
+inherit perl-module
+
+DESCRIPTION="Localization support for DateTime"
+
+LICENSE="|| ( Artistic GPL-2+ ) unicode"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/Dist-CheckConflicts-0.20.0
+ virtual/perl-Exporter
+ dev-perl/Params-Validate
+ >=virtual/perl-Scalar-List-Utils-1.450.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-Storable
+ dev-perl/Test-Fatal
+ dev-perl/Test-Requires
+ >=virtual/perl-Test-Simple-0.960.0
+ dev-perl/Test-Warnings
+ )
+"