summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-29 12:18:55 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-29 12:18:55 +1200
commit2676176599a579b10003b807b027e1535abca730 (patch)
treea516410b8745d8a456440c2c8bf60b14720fdb12 /dev-perl/Devel-CheckLib
parentdev-perl/Devel-Caller: -r bump for EAPI7 + CFLAGS love (diff)
downloadgentoo-2676176599a579b10003b807b027e1535abca730.tar.gz
gentoo-2676176599a579b10003b807b027e1535abca730.tar.bz2
gentoo-2676176599a579b10003b807b027e1535abca730.zip
dev-perl/Devel-CheckLib: Bump to version 1.140.0
- EAPI7 - Ensure tests run with no-native-symlinks toolchaining Upstream: - use Capture::Tiny instead of Capture::Output Bug: https://github.com/mattn/p5-Devel-CheckLib/issues/32 Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Devel-CheckLib')
-rw-r--r--dev-perl/Devel-CheckLib/Devel-CheckLib-1.140.0.ebuild38
-rw-r--r--dev-perl/Devel-CheckLib/Manifest1
-rw-r--r--dev-perl/Devel-CheckLib/files/Devel-CheckLib-1.14-test-toolchain.patch41
3 files changed, 80 insertions, 0 deletions
diff --git a/dev-perl/Devel-CheckLib/Devel-CheckLib-1.140.0.ebuild b/dev-perl/Devel-CheckLib/Devel-CheckLib-1.140.0.ebuild
new file mode 100644
index 000000000000..48695bb9dadb
--- /dev/null
+++ b/dev-perl/Devel-CheckLib/Devel-CheckLib-1.140.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MATTN
+DIST_VERSION=1.14
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="check that a library is available"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Exporter
+ virtual/perl-File-Spec
+ >=virtual/perl-File-Temp-0.160.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Capture-Tiny
+ >=dev-perl/Mock-Config-0.20.0
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.14-test-toolchain.patch"
+)
+src_test() {
+ unset LD
+ [[ -n "${CCLD}" ]] && export LD="${CCLD}"
+ tc-export AR RANLIB
+ perl-module_src_test
+}
diff --git a/dev-perl/Devel-CheckLib/Manifest b/dev-perl/Devel-CheckLib/Manifest
index a76bc1196f88..c4849d805dc6 100644
--- a/dev-perl/Devel-CheckLib/Manifest
+++ b/dev-perl/Devel-CheckLib/Manifest
@@ -1,2 +1,3 @@
DIST Devel-CheckLib-1.11.tar.gz 15209 BLAKE2B 786931bfcd453ce8233a3984e97b76d2761654e967dffa00b53bec5b5eb053421b0ffe29355f519de5492930ecbf7a1958cca984c5ce4a226ff01cf3878a3112 SHA512 21a64cb2ec4f3769d604eba151074daa841d40d2073a93ec186e82d8496f5ca05728c5352a31c4f07765956b85cb3144225edb51b84245b0582267af55ef2e2f
DIST Devel-CheckLib-1.13.tar.gz 15450 BLAKE2B edec53744f9f0982b94c5018907d0ea0793bbe12b64681a5b3f31818fa91e56889ff6f72d8f76e9df8ff7203afc8a2d782f610d1557da927a578f73cf256404c SHA512 2952b0ba75cc0099182aeef533749dd044518ae3df368956caa5d7d860f94658b8eadc1b1f8fabf2ba2dc3e0a3e05498f077e4cb6469609e57272b55a026cc46
+DIST Devel-CheckLib-1.14.tar.gz 15562 BLAKE2B f9e80b216dd6ee9a9949cc369e2d8f8d18f7cce8dd20f855f91ef18e6646d165c895567ad25e9b50a863e319e7320e785b1c3f5aa6cb3f65aec938786ddff01b SHA512 a5a310cd20e7bfa3c28718b0cba997e029ae0a422ed355d70774691521a3f5c2942eb39269dec1b09e706c1d124559313ab79e787430e0bb3ad43d8aa937539c
diff --git a/dev-perl/Devel-CheckLib/files/Devel-CheckLib-1.14-test-toolchain.patch b/dev-perl/Devel-CheckLib/files/Devel-CheckLib-1.14-test-toolchain.patch
new file mode 100644
index 000000000000..ec72c4574e2c
--- /dev/null
+++ b/dev-perl/Devel-CheckLib/files/Devel-CheckLib-1.14-test-toolchain.patch
@@ -0,0 +1,41 @@
+From 7e2b65b6650caa393342c0350fc60c317a7f89af Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Wed, 29 Jul 2020 12:09:08 +1200
+Subject: Hack around bad toolchain handling in tests
+
+Bug: https://github.com/mattn/p5-Devel-CheckLib/issues/32
+---
+ t/lib/Helper.pm | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/t/lib/Helper.pm b/t/lib/Helper.pm
+index f298c71..0ebc56e 100644
+--- a/t/lib/Helper.pm
++++ b/t/lib/Helper.pm
+@@ -46,9 +46,9 @@ sub create_testlib {
+ my $cc = $Config{cc};
+ my $gccv = $Config{gccversion};
+ my $rv =
+- $cc eq 'gcc' ? _gcc_lib( $libname ) :
+- $cc eq 'cc' ? _gcc_lib( $libname ) :
+- $cc eq 'cl' ? _cl_lib( $libname ) :
++ $cc =~ /gcc\z/ ? _gcc_lib( $libname ) :
++ $cc =~ /cc\z/ ? _gcc_lib( $libname ) :
++ $cc =~ /cl\z/ ? _cl_lib( $libname ) :
+ $gccv ? _gcc_lib( $libname ) :
+ undef ;
+
+@@ -59,8 +59,8 @@ sub create_testlib {
+ sub _gcc_lib {
+ my ($libname) = @_;
+ my $cc = find_compiler() or return;
+- my $ar = find_binary('ar') or return;
+- my $ranlib = find_binary('ranlib') or return;
++ my $ar = find_binary($ENV{AR} ? $ENV{AR} : 'ar') or return;
++ my $ranlib = find_binary($ENV{RANLIB} ? $ENV{RANLIB} : 'ranlib') or return;
+ my $ccflags = $Config{ccflags};
+
+ _quiet_system("$cc $ccflags -c ${libname}.c") and return;
+--
+2.27.0
+