summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-05-02 13:46:35 +1200
committerKent Fredric <kentnl@gentoo.org>2020-05-04 02:48:28 +1200
commitbd3116beaf110df50db6a7471629c1ab04ea2239 (patch)
tree72e8c390c14d04d52110a711845169fe798a89c3 /dev-perl/Dist-Zilla-Plugin-LicenseFromModule/Dist-Zilla-Plugin-LicenseFromModule-0.70.0.ebuild
parentdev-perl/Dist-Zilla-Plugin-GithubMeta: Add w/v=0.580.0 (diff)
downloadgentoo-bd3116beaf110df50db6a7471629c1ab04ea2239.tar.gz
gentoo-bd3116beaf110df50db6a7471629c1ab04ea2239.tar.bz2
gentoo-bd3116beaf110df50db6a7471629c1ab04ea2239.zip
dev-perl/Dist-Zilla-Plugin-LicenseFromModule: Add w/v=0.70.0
Required by dev-perl/Dist-Milla, which may be useful for building dev-perl/App-cpanminus from git sources Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Dist-Zilla-Plugin-LicenseFromModule/Dist-Zilla-Plugin-LicenseFromModule-0.70.0.ebuild')
-rw-r--r--dev-perl/Dist-Zilla-Plugin-LicenseFromModule/Dist-Zilla-Plugin-LicenseFromModule-0.70.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Dist-Zilla-Plugin-LicenseFromModule/Dist-Zilla-Plugin-LicenseFromModule-0.70.0.ebuild b/dev-perl/Dist-Zilla-Plugin-LicenseFromModule/Dist-Zilla-Plugin-LicenseFromModule-0.70.0.ebuild
new file mode 100644
index 000000000000..54e8c3e57430
--- /dev/null
+++ b/dev-perl/Dist-Zilla-Plugin-LicenseFromModule/Dist-Zilla-Plugin-LicenseFromModule-0.70.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MIYAGAWA
+DIST_VERSION=0.07
+inherit perl-module
+
+DESCRIPTION="Extract License and Copyright from its main_module file"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Dist-Zilla-4.300.30
+ >=virtual/perl-Module-Load-0.320.0
+ dev-perl/Software-License
+"
+DEPEND="
+ dev-perl/Module-Build-Tiny
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-Tiny-0.34.0
+ test? (
+ dev-perl/JSON
+ )
+"
+PERL_RM_FILES=(
+ "t/author-pod-syntax.t"
+)