summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-04-17 02:34:50 +1200
committerKent Fredric <kentnl@gentoo.org>2020-04-17 04:55:33 +1200
commitd1bec0891fd48e1223d53426e99bc29751f9460a (patch)
treef19fcedc48e8f284dd021e222f869266f6255fb1 /dev-perl/Dist-Zilla-Plugin-NextVersion-Semantic/Dist-Zilla-Plugin-NextVersion-Semantic-0.2.5.ebuild
parentdev-perl/Dist-Zilla-Plugin-Meta-Contributors: Add w/ v=0.3.0 (diff)
downloadgentoo-d1bec0891fd48e1223d53426e99bc29751f9460a.tar.gz
gentoo-d1bec0891fd48e1223d53426e99bc29751f9460a.tar.bz2
gentoo-d1bec0891fd48e1223d53426e99bc29751f9460a.zip
dev-perl/Dist-Zilla-Plugin-NextVersion-Semantic: Add w/ v=0.2.5
Required by app-admin/rex-9999 Package-Manager: Portage-2.3.97, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Dist-Zilla-Plugin-NextVersion-Semantic/Dist-Zilla-Plugin-NextVersion-Semantic-0.2.5.ebuild')
-rw-r--r--dev-perl/Dist-Zilla-Plugin-NextVersion-Semantic/Dist-Zilla-Plugin-NextVersion-Semantic-0.2.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Dist-Zilla-Plugin-NextVersion-Semantic/Dist-Zilla-Plugin-NextVersion-Semantic-0.2.5.ebuild b/dev-perl/Dist-Zilla-Plugin-NextVersion-Semantic/Dist-Zilla-Plugin-NextVersion-Semantic-0.2.5.ebuild
new file mode 100644
index 000000000000..355f2729d070
--- /dev/null
+++ b/dev-perl/Dist-Zilla-Plugin-NextVersion-Semantic/Dist-Zilla-Plugin-NextVersion-Semantic-0.2.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=YANICK
+DIST_VERSION=0.2.5
+inherit perl-module
+
+DESCRIPTION="update the next version, semantic-wise"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+ >=dev-perl/CPAN-Changes-0.200.0
+ dev-perl/Dist-Zilla
+ dev-perl/List-AllUtils
+ dev-perl/Moose
+ dev-perl/Perl-Version
+ virtual/perl-Scalar-List-Utils
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ dev-perl/Test-Exception
+ virtual/perl-Test-Simple
+ )
+"