summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-05-26 22:42:01 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-05-26 23:00:43 +0200
commit69c92cd732c8dc08bac82f2f923f4a6ea0de1e2e (patch)
treece12b09badc0dbd6203f171f6b96f2c0be4d458c /dev-perl/Dist-Zilla-Plugin-NextVersion-Semantic/Dist-Zilla-Plugin-NextVersion-Semantic-0.2.6.ebuild
parentmedia-gfx/feh: 3.7 version bump. (diff)
downloadgentoo-69c92cd732c8dc08bac82f2f923f4a6ea0de1e2e.tar.gz
gentoo-69c92cd732c8dc08bac82f2f923f4a6ea0de1e2e.tar.bz2
gentoo-69c92cd732c8dc08bac82f2f923f4a6ea0de1e2e.zip
dev-perl/Dist-Zilla-Plugin-NextVersion-Semantic: Version bump 0.2.6
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Dist-Zilla-Plugin-NextVersion-Semantic/Dist-Zilla-Plugin-NextVersion-Semantic-0.2.6.ebuild')
-rw-r--r--dev-perl/Dist-Zilla-Plugin-NextVersion-Semantic/Dist-Zilla-Plugin-NextVersion-Semantic-0.2.6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Dist-Zilla-Plugin-NextVersion-Semantic/Dist-Zilla-Plugin-NextVersion-Semantic-0.2.6.ebuild b/dev-perl/Dist-Zilla-Plugin-NextVersion-Semantic/Dist-Zilla-Plugin-NextVersion-Semantic-0.2.6.ebuild
new file mode 100644
index 000000000000..d7d4a56771f8
--- /dev/null
+++ b/dev-perl/Dist-Zilla-Plugin-NextVersion-Semantic/Dist-Zilla-Plugin-NextVersion-Semantic-0.2.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=YANICK
+inherit perl-module
+
+DESCRIPTION="update the next version, semantic-wise"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-perl/CPAN-Changes-0.200.0
+ dev-perl/Dist-Zilla
+ dev-perl/List-AllUtils
+ dev-perl/Moose
+ dev-perl/Perl-Version
+ virtual/perl-Scalar-List-Utils
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ dev-perl/Test-Exception
+ virtual/perl-Test-Simple
+ )
+"