summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-13 21:22:04 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-13 21:23:41 +1200
commit9930523f719b09eff69ff9092005ed04d11bccb9 (patch)
tree146f85c6e26e1464f09733003bbdd96a9b867153 /dev-perl/Email-Send-Gmail/Email-Send-Gmail-0.330.0-r1.ebuild
parentdev-python/llvmlite: Bump to 0.34.0 (diff)
downloadgentoo-9930523f719b09eff69ff9092005ed04d11bccb9.tar.gz
gentoo-9930523f719b09eff69ff9092005ed04d11bccb9.tar.bz2
gentoo-9930523f719b09eff69ff9092005ed04d11bccb9.zip
dev-perl/Email-Send-Gmail: -r bump for EAPI7 + fixes
- EAPI7 - Improve deps - Unconditionally strip harmful pod tests and resulting deps - Add custom logic to give basic "module has basic usability" test coverage. Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Email-Send-Gmail/Email-Send-Gmail-0.330.0-r1.ebuild')
-rw-r--r--dev-perl/Email-Send-Gmail/Email-Send-Gmail-0.330.0-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-perl/Email-Send-Gmail/Email-Send-Gmail-0.330.0-r1.ebuild b/dev-perl/Email-Send-Gmail/Email-Send-Gmail-0.330.0-r1.ebuild
new file mode 100644
index 000000000000..e8de85684267
--- /dev/null
+++ b/dev-perl/Email-Send-Gmail/Email-Send-Gmail-0.330.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=LBROCARD
+DIST_VERSION=0.33
+inherit perl-module
+
+DESCRIPTION="Send Messages using Gmail"
+
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-perl/Authen-SASL
+ dev-perl/Email-Address
+ dev-perl/Email-Send
+ dev-perl/Net-SMTP-SSL
+"
+BDEPEND="${RDEPEND}"
+
+PERL_RM_FILES=(
+ "t/pod.t"
+)
+src_test() {
+ local MODULES=(
+ "Email::Send::Gmail ${DIST_VERSION}"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}/blib" -M"${dep} ()" -e1
+ eend $? || failed+=( "${dep}" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in $"{failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compliation errors";
+ fi
+ perl-module_src_test
+}