summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Expect
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Expect')
-rw-r--r--dev-perl/Expect/Expect-1.210.0-r1.ebuild20
-rw-r--r--dev-perl/Expect/Expect-1.320.0.ebuild32
-rw-r--r--dev-perl/Expect/Manifest2
-rw-r--r--dev-perl/Expect/metadata.xml9
4 files changed, 63 insertions, 0 deletions
diff --git a/dev-perl/Expect/Expect-1.210.0-r1.ebuild b/dev-perl/Expect/Expect-1.210.0-r1.ebuild
new file mode 100644
index 000000000000..6e355eaa429c
--- /dev/null
+++ b/dev-perl/Expect/Expect-1.210.0-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=RGIERSIG
+MODULE_VERSION=1.21
+inherit perl-module
+
+DESCRIPTION="Expect for Perl"
+
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ~ppc64 sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-perl/IO-Tty-1.03"
+DEPEND="${RDEPEND}"
+
+SRC_TEST="do"
diff --git a/dev-perl/Expect/Expect-1.320.0.ebuild b/dev-perl/Expect/Expect-1.320.0.ebuild
new file mode 100644
index 000000000000..d7be088dacbf
--- /dev/null
+++ b/dev-perl/Expect/Expect-1.320.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=SZABGAB
+MODULE_VERSION=1.32
+inherit perl-module
+
+DESCRIPTION="Expect for Perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ virtual/perl-IO
+ >=dev-perl/IO-Tty-1.110.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ test? (
+ virtual/perl-File-Temp
+ >=dev-perl/Test-Exception-0.320.0
+ virtual/perl-Test-Simple
+ )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Expect/Manifest b/dev-perl/Expect/Manifest
new file mode 100644
index 000000000000..7d8aa3cd1f10
--- /dev/null
+++ b/dev-perl/Expect/Manifest
@@ -0,0 +1,2 @@
+DIST Expect-1.21.tar.gz 53881 SHA256 e5509307b8e330a3bc07dd4ab1d28e5451116449cc9c3bdabb1235f66ce62267 SHA512 496716b9e6544e9d6809b7f704df8199291d18ec9ec9ebb4fd2b7b341aa10d9b03989335c1f22d1faddbff0974ceba5b2823685fa08ce6a75e2f3ccaeb944e74 WHIRLPOOL d749b06519afc243af06a0d17610be6acb522a00982df7afe0a9122f18d11daadf222414f7171f86bb19f1f150512d32ccca94c45dac85f29eca605a1bda8c2c
+DIST Expect-1.32.tar.gz 61592 SHA256 d1f96842a5c7dd8516b202b530d87a70b65e7054d3bf975c34f6a42084e54e25 SHA512 0281d1662a902b99b5131c017b50b0456c3461c176bf4485b4bb383cab009973605514256540c5ddc2e274b5dd92ece5555719f5527d3fb8c35e83f8dc038147 WHIRLPOOL acd78f455507947fc8953cc3b2fc10a33f7b1926ecbebb61ae69812b57ae7273dc8294035f08fa4d248e046d6f79a81ff694c069ffbe3479608bbb32e1cd0734
diff --git a/dev-perl/Expect/metadata.xml b/dev-perl/Expect/metadata.xml
new file mode 100644
index 000000000000..208e37f1672b
--- /dev/null
+++ b/dev-perl/Expect/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Expect</remote-id>
+ <remote-id type="cpan-module">Expect</remote-id>
+ </upstream>
+</pkgmetadata>