summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-29 11:45:05 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-29 11:47:16 +1200
commit7673c9474da74a2a7c559d106c0c666bfee16cb1 (patch)
tree2be192fd98c2c4b000cb95a2445defd6c41c31c0 /dev-perl/File-LibMagic
parentvirtual/rust: Stabilize 1.45.2 arm64, #739310 (diff)
downloadgentoo-7673c9474da74a2a7c559d106c0c666bfee16cb1.tar.gz
gentoo-7673c9474da74a2a7c559d106c0c666bfee16cb1.tar.bz2
gentoo-7673c9474da74a2a7c559d106c0c666bfee16cb1.zip
dev-perl/File-LibMagic: -r bump for toolchain love + fixes
- Remove rm-files logic from src_prepare (the files are gone upstream) - Fix being broken by LD being set in ENV to an actual LD instead of a CCLD - Ensure CFLAGS passed to make/compiler, but much more differently than is usually done due to some fun behaviour upstream that breaks binary asset persistence between 'make' calls. - Add missing remote-id's - Add missing (virtual) dependencies. Bug: https://github.com/houseabsolute/File-LibMagic/issues/28 Package-Manager: Portage-3.0.4, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/File-LibMagic')
-rw-r--r--dev-perl/File-LibMagic/File-LibMagic-1.220.0-r1.ebuild50
-rw-r--r--dev-perl/File-LibMagic/metadata.xml1
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-perl/File-LibMagic/File-LibMagic-1.220.0-r1.ebuild b/dev-perl/File-LibMagic/File-LibMagic-1.220.0-r1.ebuild
new file mode 100644
index 000000000000..c2d48c908888
--- /dev/null
+++ b/dev-perl/File-LibMagic/File-LibMagic-1.220.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR="DROLSKY"
+DIST_VERSION="1.22"
+
+inherit perl-module
+
+DESCRIPTION="Perl wrapper for libmagic"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ sys-apps/file
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ virtual/perl-XSLoader
+ virtual/perl-Scalar-List-Utils
+"
+BDEPEND="${RDEPEND}
+ dev-perl/Config-AutoConf
+ virtual/perl-ExtUtils-CBuilder
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
+src_configure() {
+ unset LD
+ [[ -n "${CCLD}" ]] && export LD="${CCLD}"
+ # Note: the usual approach of passing this to compile doesn't work here
+ # as something is weird and recompiles the code 3 times, once in `make`,
+ # once in `make test` and once again in `make install`, the latter clobbering
+ # the same files generated in other passes. The only sane way to avoid this is
+ # to convince EUMM to hardcode the settings in Makefile, and at least then, it does
+ # the same thing in all 3 stages. BUT THIS SHOULDNT BE HAPPENING
+ # https://github.com/houseabsolute/File-LibMagic/issues/28
+ myconf=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_configure
+}
diff --git a/dev-perl/File-LibMagic/metadata.xml b/dev-perl/File-LibMagic/metadata.xml
index 89daaefc1d56..f40eb4f38cd5 100644
--- a/dev-perl/File-LibMagic/metadata.xml
+++ b/dev-perl/File-LibMagic/metadata.xml
@@ -14,5 +14,6 @@
<upstream>
<remote-id type="cpan">File-LibMagic</remote-id>
<remote-id type="cpan-module">File::LibMagic</remote-id>
+ <remote-id type="cpan-module">File::LibMagic::Constants</remote-id>
</upstream>
</pkgmetadata>