summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-29 13:23:45 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-29 13:23:45 +1200
commit639705816a21df931b1102419c05d1c30ef3a7fb (patch)
treeb9f2f82013ffde8a4f2c5ecb36b40796ee49fc18 /dev-perl/File-Map
parentdev-perl/PerlIO-Layers: -r bump for EAPI7 + toolchain love (diff)
downloadgentoo-639705816a21df931b1102419c05d1c30ef3a7fb.tar.gz
gentoo-639705816a21df931b1102419c05d1c30ef3a7fb.tar.bz2
gentoo-639705816a21df931b1102419c05d1c30ef3a7fb.zip
dev-perl/File-Map: Bump to version 0.670.0
- EAPI7 - Ensure not to break when LD is set to a non-ccld - Ensure passing CFLAGS to compiler Upstream: - Fix unresolved symbol 'madvise' on QNX NTO - Warn when buffer is truncated - Fix mapping into a hash element - Fix compile warning in boot function return type - Accommodate for sleep 0.1 possibly being less than 0.1 Security: - The following notes in changelog indicate some exploit/DOS possibilities - Warn when buffer gets truncated Given this stuff is implemented in C, some analysis for severity is needed. Reference: https://github.com/Leont/file-map/commit/c5c60d5c3af9ff924f95c7aab70740f002ac6898 Package-Manager: Portage-3.0.4, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/File-Map')
-rw-r--r--dev-perl/File-Map/File-Map-0.670.0.ebuild42
-rw-r--r--dev-perl/File-Map/Manifest1
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-perl/File-Map/File-Map-0.670.0.ebuild b/dev-perl/File-Map/File-Map-0.670.0.ebuild
new file mode 100644
index 000000000000..e99adaf70939
--- /dev/null
+++ b/dev-perl/File-Map/File-Map-0.670.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=LEONT
+DIST_VERSION=0.67
+inherit perl-module
+
+DESCRIPTION="Memory mapping made simple and safe"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/PerlIO-Layers
+ >=dev-perl/Sub-Exporter-Progressive-0.1.5
+ virtual/perl-XSLoader
+"
+DEPEND="dev-perl/Module-Build"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.280.0
+ test? (
+ virtual/perl-IO
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Test-Fatal
+ virtual/perl-Test-Simple
+ >=dev-perl/Test-Warnings-0.5.0
+ virtual/perl-Time-HiRes
+ )
+"
+src_configure() {
+ unset LD
+ [[ -n "${CCLD}" ]] && export LD="${CCLD}"
+ perl-module_src_configure
+}
+src_compile() {
+ ./Build --config "optimize=${CFLAGS}" build || die
+}
diff --git a/dev-perl/File-Map/Manifest b/dev-perl/File-Map/Manifest
index 6bd07ab93eda..d73e5c32beea 100644
--- a/dev-perl/File-Map/Manifest
+++ b/dev-perl/File-Map/Manifest
@@ -1 +1,2 @@
DIST File-Map-0.64.tar.gz 78083 BLAKE2B 66e11275141e72782e9fb4dbb4bbfad75600de0a2b88671d858fe8df2f9a05cd71603998def5f480fe672fb240e4b97b6b2137a4563d9139372f269b9104f4af SHA512 dc1182e79d20e835e19c78f5187dd108b45938209933a7074674d472ac300277fc1fb7604b023ad7d3456ef5837bb8274a94e1cac79f95f2a2235855c59d3809
+DIST File-Map-0.67.tar.gz 104595 BLAKE2B 6a35bb47ca606d905806f8c49cef853067db3f391db3f27657d5b1cf66e24520734ce3aa8f9725d25c859190365bf3bac2a617131bdc99746a0afe5a552dab6a SHA512 52bd9ebb546e6b0e0d58cce3e5f5983c0f89bf05ba3f29d220b6d83ca150e200ac9c6e7d2adb717838c0b20e9ddd68c94509b47775d27273c37bc44dcff1d507